Prototype full width NOT working!

Hello,

I think your update for prototype has disabled or removed full width mode?

2 Likes

All options are present for me like always:

image

@Gleb present is one thing…actually working is another. Does not allow full width like before. Does full height which is incorrect.

Can you show some screenshots?

Are you sure the frame you are viewing is larger than your display resolution? The “Width” option only can scale the frame down. And this option works as expected for me.

yes i’m sure. the funny thing is I have never changed my resolution since i’ve been using figma?

This is not only happening to me, my whole UX team and Product Team now views it this way. This is not an isolated case.

What’s the size of the frame?

All our mockups are at 1440px, resolutions on our macbook pros are 1440

any resolution on this issue? It is a known issue on our end and our whole team has full width screen issues both on laptop and desktop monitors @Gleb

Maybe you changed interface scale?

Nope, I think this calls for a zoom call so you can see all my teams settings so we can end this back n forth

Note that you can’t change interface scale settings when you are on the prototype tab, you can only change them on the file tab. And by your screenshot the size of the font in Figma looks suspiciously small, that’s why I’m still suspecting you don’t have the 100% interface scale set or your frame is not actually the size of your screen. I can’t replicate this behavior myself. I just took a screenshot, made it 2x smaller because I’m on Retina, then I wrapped it in a frame and opened in the prototype, everything is fine, it fills the whole width in Width mode.

Make sure you are in the file, not in the prototype, and reset the interface scale.

Oh, also maybe you have some elements sticking out of the frame or you have a drop shadow on it. Make sure the main frame has “clip content” enabled and you don’t have any effects on it.

I don’t give free personal consultations, so I won’t jump on a zoom call unless you are ok to pay me. But I think I just gave you everything I could think of, this answer would probably end the back and forth. Unless it’s actually a bug in Figma, in which case you’ll need to reach out to Figma support team.

Any updates?

I also have the same problem. i have old files in which it used to show the (width-scale down to fit width) option and it still shows when i open this old file and play the prototype, But for the new files i create the option is not available.

1 Like

This is still relevant. Maybe it’s because I am using the larger resolution on my macbook 13 inch. But it worked before. I was not using figma for a year or so for desktop designs tho. When I put the interface scale at 120% then it’s fine, but the UI is just HUUUGE and it’s taking in the space I wanted to have when switching to a larger resolution. Please fix it and just make it take 100% of the window size instead of anything display resolution based.

Has the prototype menu been redesigned recently? I used to have an option called “Fill - scale up or down to fill” but it is missing from my prototype menu and now I can’t scale my (responsive) design up to fit the device (the design is iPhone 8 and the device is iPhone 13)

I only have these options in the prototype option menu:

  • Actual size (100%)
  • Fit to screen
  • Fill screen (Z)

none of the options scale the design up.

Also having this problem with full width prototypes, really frustrating. I’m using the iMac frame (1280 x 720) which I can get to display full width at these exact dimensions, but when I go on to design the rest of my landing page design and increase the height beyond the break point, it then won’t display full width on any of my screen sizes (laptop, desktop etc).

Read a few forums, blog posts and can’t figure it out!

Same with me. In one page I can see Fit width option, but same prototype pasted in another page does not allow it. It’s weird.