Pinch-to-zoom unreliable

At least 2 or 3 times per day, I will be going back and forth between applications and when coming back into Figma, the pinch-to-zoom on my track pad will not work. It works perfectly on every other application (even while it isn’t working on Figma). I haven’t been able to recreate the issue with a specific sequence of events. It seems to be haphazard.

Who else is experiencing this? Has anyone been able to recreate this issue? It’s not a trackpad or MacOS issue (since the pinch-to-zoom still works perfectly alongside when Figma isn’t responding to it).

57 Likes

This happens to me all the time and is so frustrating! I have no idea what the cause is, because it happens randomly and unpredictably.

Sometimes, going into macOS Setting → Trackpad → Pinch to Zoom → Change from enabled, to disabled, then back to enabled will fix it. Other times, I need to do a full restart to fix it.

Sometimes, opening Sketch will cause only one of the apps (Figma or Sketch) to still have pinch-to-zoom. Other times, they’ll both be able to use the trackpad normally.

Sometimes pinch-to-zoom will work in Figma, but not in a browser I have open. Sometimes, it will work in a browser, but not in Figma.

I have no clue what is causing the problems, but I’m guessing it’s a Figma-related bug because that’s the app I always have open when it happens.

14 Likes

First time this happened to me and I just realized that this is my most common gesture, making it impossible to design anything. Thanks for the tip, Joey—worked for me.

I had the same issue: Pinch to zoom wouldn’t work in Figma. I went into system preferences to check the trackpad and noticed it had little battery (10 % left). I added it to a charger, and suddenly pinch to zoom worked in Figma.

1 Like

EDIT:
Problem came back later in the day :pensive: I’m also on an M1 macbook air

ORIGINAL:
This is fixed for me now!! I’m not sure if it was fixed in the 32 Little Big Changes update, or if it was because I just uninstalled some stuff.

Uninstalled

  • LogiOptions (app from Logitech — I thought I had already uninstalled it, but it turns out Logitech has more than 1 app that it installs). I found an uninstaller in /Library/Application Support/ , ran that, and that uninstalled the app.

  • Adobe products except for DC — I’m planning to reinstall once I need fonts/etc, but I don’t use anything very often so mostly just wanted to uninstall it to make sure it wasn’t wasting system resources/slowing down my bootup times.

Now I’m able to have huge Figma files open AND have a huge Sketch file open, and pinch to zoom works in both! That never happened before!

Latest version of Figma (107.1) and trackpad still stops working after switching between apps. I just got a new laptop and this problem didn’t exist for me on MacOS BigSur and a non apple silicon laptop.

1 Like

@anon21722796 When is this going to be fixed? This has been an issues for over a year? I love Figma, but this is such an annoyance that I am considering moving to Sketch.

Macbook M1 and also often encounter this problem lately. It appeared this problem relatively recently, maybe two or three months ago. Only the restart of Figma helps, but this is somehow not very good)

@anon21722796 Please can we get a fix for this?

ZOOM doesn’t work which means either a full restart, a quit Figma or switching off pinch to zoom and back on again, all of which aren’t guaranteed to fix the problem.

I am thinking of moving to Sketch :frowning: or XD

This seems to be a more recent issue for me too — I’ve been using Figma for a long time and never had zoom stop working until these past couple weeks.

Same here.

This is becoming really disruptive in my work and @anon21722796 is not even acknolegking that there is an issue. I have to restart the app and sometime the whole machine.

@anon21722796 this is a massive bug that hinder our productivity.

Same here! @anon21722796

@anon21722796, please fix this bug, it is a known issue for a long time now and happening for a lot of users as reported here. I hate restarting all the files and tabs that I have closed because the pinch and zoom features are not working.

Same issue for me. It happened multiple times during the day (on Figma & Figjam files) and more and more often since few days. Very annoying and frustrating because i can’t work during few minutes.
The pinch zoom issue is only on figma, it works on other software.
I’m on MacbookPros 2019, with no external trackpad.

Same here @anon21722796
restarting the app did not help.
Happend after I made a screen grab in Miro

Almost full battery, but saw the comment about plugging in the laptop to the charger and it helped

Same issue here - M1 MacBook Pro, web version of Figjam. Trackpad control is maddeningly unreliable - sometimes it stops working altogether, pinch to zoom only works around 80% of the time, and swipe gestures are often misinterpreted, invoking the browser ‘back’ behaviour. I was a long-time Miro user and didn’t have these issues with that tool.

Same here. @anon21722796, please address. Our entire UX org is relying on Figma functioning. This is a very annoying and time-consuming issue / bug.

Thanks turning the mac pinch setting on/off did it!!

1 Like

Still randomly affecting me. Turning the pinch setting on/off in mac settings didn’t help. CMND+R won’t refresh the Figma window either while pinch/zoom issue is active. Restarting browser and clearing cache had no affect. Bug magically resolves itself after 15-20 min.

Same here on MacBook Pro, 2017
It happens 2 to 3 times per hours
Have to close and re open to fix
Will really appreciate a fix or workaround