Figma links always open in browser, not desktop app

Same issue. Really annoying lately as we are sharing mostly links in Slack rather than sending invites on email.

Started around a month ago just around when this thread was opened. Couldn’t find a proper fix.


Same problem here!
Both - desktop app and browser - do not open my files :worried:

1 Like

Same for me. Also the menu option “Open file in desktop app” is gone. Instead it says “Get desktop app”. :frowning:


Same issue here. Made sure per the support doc that both are signed in to the same account. No dice.

1 Like

I’ve been experiencing the same issue for a few weeks now. Even switched browsers from chrome to Safari but links still open in browser when open in desktop app option is selected

1 Like

Having the same issue! Not sure what started the change in experience but it’s very frustrating… as someone who uses Figma all day, every day I am constantly avoiding the browser experience :frowning_face:

1 Like

Same fo me and that is really annoying when working with teammates.
“Open file in desktop app” is gone.
Instead it says “Get desktop app”


For those coming to this thread looking for an answer - it looks like you need to be signed in to the same account in both the browser and desktop for the ‘open file in desktop’ option to appear.

If you’re signed in to different accounts on the desktop and browser, say, a personal and work account, the wires get crossed.


Nope, not working. Signed (same account) and still showing “Get Desktop App”

Reinstall Figma app, it works for me :slight_smile:

Same here. Incredible annoying. I tried deleting my browser cookies, cache, and history. I reinstalled Figma. I reinstalled Chrome. I’m using the same account. Nothing works.

1 Like

Same here, signed with the same account and still have this message “Get Desktop App”.

I have the same problem. Reinstalling the application did not help.

Experiencing this issue today as well. App is installed, won’t acknowledge I can open the document in it.

On macOS, I was able to fix this with Choosy.

My rule is
All web addresses containing “
Always use this browser:

Hah, what an insane (and brilliant) workaround.

Unfortunately, I copied your rule exactly and made Choosy my default “browser,” and it still doesn’t work for me :confused:

Having this problem now. Even when open in Desktop is selected still opens in Browser. Problem just started today.


Hey all, we’re looking into this now. Thanks for reporting

Hey all this should be fixed now! You might need to refresh or restart your computer. Apologies on the inconvenience here.

Let us know if you still run into this after restarting

1 Like

Fantastic work, Josh. Fixed the issue for me.

I had to do a full restart, then the browser prompted me, “Do you want to open this file in the desktop app?” After selecting “Always open in the app,” the issue is resolved.


1 Like

As of about a week ago, Figma links no longer open in my app. This can be a problem since the browser can not support the size of the file and may reload over and over.

The option to open in app doesn’t pop up and if you go to the Figma logo is says “get the app” instead of “open in app” despite having the app open at this moment.

What can I do?