Figma Support Forum

Figma Links Not Opening in Desktop App, Despite Setting

Anyone else having an issue opening Figma links in their desktop app? I’m using MacOS and trying both Chrome and Safari.

The link does switch focus to the Desktop App, but it doesn’t open up to the linked file/page/frame. Turning the “Open in Desktop…” setting off allows the link to open correctly, but in the browser.

2 Likes

I’m experiencing the same issue (I think?).

Figma links only open the browser, despite having “Open links in desktop app” turned on.

Same for me… spent almost an hour trying to get access to a file in the Desktop app, and no result…

Also having the same issue. Not sure what to do

Same issue. Really annoying lately as we are sharing mostly links in Slack rather than sending invites on email.

Started around a month ago just around when this thread was opened. Couldn’t find a proper fix.

Same problem here!
Both - desktop app and browser - do not open my files :worried:

Same for me. Also the menu option “Open file in desktop app” is gone. Instead it says “Get desktop app”. :frowning:

4 Likes

Same issue here. Made sure per the support doc that both are signed in to the same account. No dice.

I’ve been experiencing the same issue for a few weeks now. Even switched browsers from chrome to Safari but links still open in browser when open in desktop app option is selected

Having the same issue! Not sure what started the change in experience but it’s very frustrating… as someone who uses Figma all day, every day I am constantly avoiding the browser experience :frowning_face:

Same fo me and that is really annoying when working with teammates.
“Open file in desktop app” is gone.
Instead it says “Get desktop app”

1 Like

For those coming to this thread looking for an answer - it looks like you need to be signed in to the same account in both the browser and desktop for the ‘open file in desktop’ option to appear.

If you’re signed in to different accounts on the desktop and browser, say, a personal and work account, the wires get crossed.

1 Like

Nope, not working. Signed (same account) and still showing “Get Desktop App”

Reinstall Figma app, it works for me :slight_smile:

Same here. Incredible annoying. I tried deleting my browser cookies, cache, and history. I reinstalled Figma. I reinstalled Chrome. I’m using the same account. Nothing works.

Same here, signed with the same account and still have this message “Get Desktop App”.

I have the same problem. Reinstalling the application did not help.

Experiencing this issue today as well. App is installed, Figma.com won’t acknowledge I can open the document in it.

On macOS, I was able to fix this with Choosy. https://www.choosyosx.com/

My rule is
All web addresses containing “figma.com/file
Always use this browser: Figma.app

Hah, what an insane (and brilliant) workaround.

Unfortunately, I copied your rule exactly and made Choosy my default “browser,” and it still doesn’t work for me :confused:

Having this problem now. Even when open in Desktop is selected still opens in Browser. Problem just started today.

3 Likes