Figma Community: Changing pages in resource preview embed not working

I don’t know if this is only happening on my end. I have tested on multiple browsers.
When viewing a file in the Figma community, I try switching pages in the preview embed box and it doesn’t seem to work. is this just on my end or an actual bug?
Its hard to preview files before downloading.



I’m with the same problem.


As of a few days ago I am having the same issue. Really annoying as I can only see the cover and not the extra preview pages!


Same. Just published a new library/kit today and this functionality is not working.

i have same problem for 1 week

1 Like

same here :smiling_face_with_tear:

1 Like

Same here :sob::sob:

I am facing the same problem since week! and this is Annoying.

In the Figma community space the button for choosing pages no longer works, even if you change pages the content in the frame does not change

Hello everyone!

I’m having an issue with the “Preview” mode for community projects. When I click on any project, I can see the number of pages in the file, but I’m unable to view the designs of the other pages after clicking on them. Nothing changes.

Does anyone know how to fix this so I can quickly review the pages like before?

1 Like

Hi @dvaliao Thanks for your extensive reply.
Maybe there is a misunderstanding. I’m not trying to embed a Figma file. I’m referring to files/resources published to the Figma community, for instance, this.
Figma handles the embed, not me.
Can you please take a look at the link or any other resources and attempt navigating to any other page in the file? Let me know if you have the same experience or not.

Thanks for clarifying and sorry again for the oversight, @Ojanti!

We’ve flagged this over to our community team and filed a bug to have them continue to investigate.

@dvaliao I can do what you asked but this isn’t just MY issue. Its an issue with the community website. I just observed the problem on every resource/landing page of the top 25 files from a search result.
Each one had the same problem. Please test and let me know. Did Figma community moderator flag 100s of files suddenly? I have not seen a single file/resource that doesn’t have this problem and the fellows above seem to have it too.

Hey @dvaliao I am fully aware of this :smile: . Its been like that for a while.
Did you actually attempt to change the pages and it changed successfully?

This is the exact bug being reported. Let me know if it worked, on that file or another

Hey @Theotrait , thanks for flagging this! We have shared your feedback to our team.
Others in the community have also flagged it, i’ve gone ahead and merged your topic with this one so we can gather all the feedbacks in one place:

It works now! :pray:

how did it work for you? can you shed some light?

The recent update on the draft and organizational structure is ridiclous. :melting_face: Not only is there an embed preview bug, which seems like a by-product of the update, but we are also being asked to choose an organization every time we click on the “Open in Figma” button.

When you navigate between those pages now you can the preview of each one.

It looks like the problem is solved, thank you!