Stacked dropdown filters

My stacked dropdowns are not pushing the frames down and appearing behind the the other filters - how do i fix this?

Change the order of the layers so that the first object is on top.

If you are using Auto Layout then change the “Canvas stacking” option.