Prototype not updating after updating component

My prototype refuses to update a component i changed in the editor. even when I remove it from the frame it still doesnt update.

I cleared my browser cache, restarted comp, even create a duplicate file, but still no luck.

This feels like a bug to me. Can someone help?


Can you record a video, share the file?

the first screenshot is the glitchy frame that doesnt update, a few frames over in the prototype is the second frame that DID update properly

Can you record a video, share the file? Screenshots just showed what you were saying but they don’t help investigate the issue.

i tried but video wont upload, error appear on processing upload.

That’s weird, maybe you can upload to youtube or google drive then? A shared file link would be nice as well, may be even better than the video.

Hmm that is weird. I can’t tell what’s wrong from the video. If you can share the file I may be able to find something but I don’t know.

Unrelated to this issue: this toolbar in the middle of the screen is killing me. :sweat_smile: Did you know you can put it to the bottom of the scroll screen and set constraints to Bottom in order for it to stick to the device bottom? This way it won’t cover any content.

Ok I think I see the issue. See how the frames names are a bit more dark gray than the other ones?

That’s because there are two frames with the same name stacked on top of each other, you probably duplicated them accidentally. So you are changing the top frames while the prototype probably works with the frames at the bottom which were created first.


I dont think thats the problem. Here is the editor link:

That’s exactly what the problem is.

1 Like

you’re right, i was looking at the wrong frame. thanks again!

Hi, I’ve the same issue where the prototype doesn’t update after updating master components. I’ve already published the changes, updated the page, and the component in my design file links to the edited master component - it just doesn’t show the changes to the master component even when I reset all overrides.

I’ve prepared a video, but I can’t upload videos because I’m a new user.