Problem with connecting screens

Im new in UX as on Figma and I m creating a hi-fi Prototype. When using present mode to play the flow between screens , it gets stuck on one screen. I clicked on prototype menu and checked all the connections between buttons, everything is similar to all other screens that are flowing well, but still wont work on that one screen. what could it be ?

If you unplugg a connection and after drag a new connection Figma will set you up with a second interaction, most likely something other than On Tap/On Click since that is the default. So make sure that all connections are using the correct event trigger.

If that doesn’t work then try closing and opening the presentation tab again. And if that doesn’t work try restarting Figma.

1 Like

Thank you !
I tried all this, still doesn’t work. the gesture I m making in this screen is Touch down/open overlay/manual. this is the only difference from other screens.

Could you share the file?

1 Like

seems i can t share links here . any other way how i can send it to you ?

put a space between the dot. like so: figma. com/restofurl

1 Like

thank you i fixed that, thank you for your interaction :blush:

hello! I have the same problem and cannot seam to solve it. The connections on prototype mode all seem to be connected but when I play it, only one screen connection works.

Hi all. I have a similar problem. At some point in the flow that works, the prototype connection is bringing me to the starting page instead of the one that is connected to. I tried restarting Figm, redoing connection with other variations (dissolve/instant etc.), I tried web. All the same. Any ideas why it’s navigating to the wrong page? I even tried some extra element in the middle of the screen to connect to this other page and still, it moves me to the starting page.
(an element is part of horizontal slider frame)

Can you share a file?

Well, 7h later I fixed it!
I had a cut-out for a shaded background that was an ‘exit’ to the starting page. I needed to move it on layers list down because apparently it still worked as coverage of full area instead of cut-outs part. Solving this felt good :slight_smile: