Preserve Scroll Position - (not working, please roll back the feature)

Hey, i face a bug since there has been an update on the preserve scroll position behavior yesterday. By now the former preserve scroll position, which i had to set manually before is now set as default. So i don’t need to tick the box anymore.

But, in my protoype, although i expect now that the scroll position is preserved by default, it is not working correctly. From screen to screen my prototype is jumping to the top. I need to ship my proto today to the client and this is super annoying.

Anyone faces the same issue since yesterday? @Figma_Support can you roll back the feature? :pray:


I have exactly the same issue… which kind of “ruined” my prototype. Anyone can help?


“the top level frame name should be identical with the target frame, otherwhise the preserve scroll won’t work.” This works to me

1 Like

You need to create variant to preserve scrolling position

I also faces the same issue since yesterday. @Figma_Support please roll back the feature.


Hi all, if you are experiencing an issue we would like to take a closer look. Would you mind reaching out to our support team so they can assist further Submit a bug form →

same here… its super annoying

1 Like

Same thing. Prototypes break and start twitcing on interactions.


I’m having the same issue here! The suggestion to make sure the top-level frames are named the same did seem to fix it, but it’s not an ideal solution when my frames are named separately for a reason… Hopefully we can get a fix for this!


I’m facing the same problems here guys! It seems to be more like a bug from this new update, to me you know. Like our friend @phroobin said, when we change the names of the frames to the same name, it works pretty well. But i’ve got 35 frames here dude, so we do need to give different names to identify those guys later. We all need to report this bug to the Figma Support, I guess. The more we all report, the sooner they will hear us and take a closer look at this issue. So let’s do it! :+1:t4:


Why is there silence from @Figma_Support about it? This is a big issue. I have to use another tool.


I have the same issue and it is a big problem. When can this get fixed or rolled back?


Hey @Figma_Support! Can you guys help us by fixing this bug please? :pray:t4:

1 Like

Answer from @Helge_Wadewitz works for me. All frames where you want scroll position to be preserved must be named the same. Seems like much the same way that layers must be named identical for smart animate to work.

Regardless, its frustrating not being able to name frames with different names. @Figma_Support please fix this.


It is totally untenable/unworkable to have to name top-level frames identically to get prototyping working correctly. I shouldn’t have to conform my system for naming top-level frames to get prototyping to work correctly. This was NOT an issue or requirement in previous state management. And even when I do name them the same, the scroll position still jumps several pixels between frames.


Having the same issues as everyone else mentioned in this thread and prototype looks flawed. I need this to present to important clients but not in its current state. It looks unprofessional and clunky in and @Figma_Support needs to help sort this for everyone as soon as they are able?

1 Like

I created frame in middle of page frame, and added hover state.
Now when test in prototype it simple throws me on top on new frame…

Earlier was there ‘preserve scroll location’ now it’s missing. There is something new ‘Reset scroll position’ which is turned off. That means preserve is default. But it’s not working …


I’m seeing the same issue with hover states and am missing the option to “preserve scroll position.”

I have hover interaction low on my page and now in prototype, when I hover over that instance, it brings me to the top of the page. If I “roll-off” the area that the hover is connected to, it will bring me back to the original position of the non-hover state.

If I check “reset scroll position”, it makes it so there is no “roll-off” motion—it keeps me at the top of the screen with the hover state design activated (though you have to scroll to see it).

1 Like

Also missing this function when I want to “perserve the scroll location” when I jump between two wireframes. Worked before but since Reset scroll position and Reset componentstyle is the new option, I can’t find a way to get it working as before :frowning:

1 Like