Paste and replace not working on MacBook

There is no paste and replace option on the menu after I copy the object and when I use command+shift+R, it turns into rename action. Is there anyone know how to fix it?

Hey @Ying_Chen1,

The keyboard shortcut to replace should be shift+command+R.

More info available here:

Hello, it’s still directing to the rename action even if I press shift then command and r.

Hmm… that’s odd. The shortcut to rename layers should be only Command + R.

Have you tried creating a new set of objects to test? If it’s happening with something specific, it may be a bug.

We just tried to reproduce again with a new set of objects, and when firmly holding down shift + command then R, it replaces as expected.

Hi, my panel shows that the shift+command+r as the shortcut to rename for some unknown reasons. And there is no paste to replace option on the menu after I copy the item.

when I hit command+r, it refreshes the page

Thanks for the info and screenshots! What keyboard layout are you using?

Perhaps you’re using a layout with remapped shortcuts. More info here:

Hi, It turns out that I have a remapped keyboard for shortcuts even though I just bought this computer several days ago. Could I ask is there a way to change it back.

My keyboard is US generic

Yes. Please try the following:

  1. Click in the bottom-right corner of your screen and select Keyboard shortcuts.
  2. Select the Layout tab.
  3. Use the dropdown to update your layout. Preview keyboard layouts by hovering over each option before selecting it.
  4. Select Generic to revert to the default keyboard layout and use Figma’s default mappings.

Hey, my keyboard is already generic. It doesn’t work.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Hey @Ying_Chen1,

In that case, this definitely seems like a bug. Please submit a bug report to our support team directly via the form here: