Inner frame doesn't fill outer auto-layout frame, nor vice versa

I created a frame (“A”) and nested a frame (“B”) within it. Months ago the way it worked was that I could drag to change the height of B, and then A would resize accordingly. Having been working with Figma for almost 2 years now, I have a good familiarity with the interface.

Basically, A models a webpage with the width being “device width”, and B models a “max-width” CSS value.

There are two approaches:

Approach 1: Make B have fixed height, and let this be the “control”. The control is the frame that I manually drag to quickly change the height of the content area in my wireframe. In this scenario, A should automatically resize to match the height of B because A is set to “hug”.

Approach 2: Make A have fixed height and set B height to “fill”.

Neither of these approaches was working. No matter what I tried, B height only offered “Fixed” and A didn’t offer a “Hug” option, despite the fact that A was already set to auto layout.

At the last minute, I decided to try disabling auto layout on A then re-enabling it. That worked. This was analogous to “Windows isn’t working right so let’s restart it” in that it doesn’t make sense why that should fix it but it does.


Delete auto layout from A and re-add.

This definitely seems like a bug, but in case they never fix it or it only affects a few, I hope this post will save others a bit of time and frustration.

#imDoingItRightButStillNotWorking = bug


Here are the other posts I looked at related to this issue: