Fix Outline Stroke

I know this was an issue on the old Spectrum forum that doesn’t seem to have any ground here, and it still is an issue.

See quick video with imported complex vectors and a simple heart made in Figma.

Any idea when this bug will be addressed? Dropping it into Illustrator is not an appropriate solution.


Regarding bugs please reach out to Figma support team via the support request form.


Submitted it. If there is a helpful response I will upload to this thread.


This is so annoying


Is there any solution for this? I’ve noticed that this bug occurs only with center stroke if it helps.


Guys, I think I found a work-around that worked for me.

In my case, I wanted to expand the vector boundaries by 1px. What I found is that when I set it to 0.5px (used the “outside” option) the bug didn’t occur. Then I Outlined > flattened and applied the same process to the new vector. It worked again!

The result was that at the end I had a 1px path-expanded vector.

Hope this helps.


Nov 2021 and this still hasn’t been fixed! It’s something I have to deal with on an almost daily basis. Exporting to Sketch or Illustrator is not a real fix! C’mon Figma get your act together.


I have this problem all the time and have to use Illustrator. Is there a fix coming?

hello, what is happening here? I cannot believe this is still not fixed… :frowning:

I contacted figma support about this, and the operator answered that this is a difficult issue to fix. I guess that the devs must rework the vector network from the scratch.

I to have found a work-around. If this happens, you should export the icon as a svg and re-import is in Figma.


I have the same issue for a while now, over a year I’d say. Sometimes cleaning up some paths helps but nothing really obvious. I tried reducing it from 3px to 1px line and it worked but when I added a stroke to that 1px and tried to expand the lines, same thing happened. No choice but to tediously export as SVG, bring into the all-mighty Illustrator to expand the path, merge and copy and past back into Figma.

Outline stroke > Make sure two new shapes are selected and different colors (see below) > Subtract Selection > Flatten

Make sure stroke is white, and other shape is black.

1 Like

Here to say this is still happening for me — very annoying

Occurs with Outside for me

I have the same issue. Especially annoying if you have to convert line icons. @Figma a fix would very be much appreciated.


Hey All,

This is a long standing bug that our engineers have been continuously logging and trying to fix. This generally only happens on icons imported from other apps, where the mirroring on the points is reversed or missing.

Right now, the best workaround is to rebuild affected icons from scratch. Please note that redrawing with fewer points can also help.

While we can’t guarantee an ETA on a fix/improvements, please know that our team follows this thread and takes everything you provide into consideration.


Sorry, but this happens with icons created in Figma and coming from Figma plugins as well. It’s great to know the team is working on it, I hope they’ll find a way soon because it’s very problematic.

Most other vector apps don’t have such issue, someone proposed a (maybe incorrect) explanation here.

I’m glad that you know about this issue and you’re working on it. However, it’s been there for many years now and it’s sad that it’s still unresolved. I’m wondering why other vector apps don’t suffer from the same issue…

I’m working with some icons now and it happens to literally half of them. Very annoying because I have to use a different software, because Figma would be otherwise perfectly capable of handling these simple edits.

It’s not working me :frowning: