Figma Support Forum

Files not opening - stuck on loading screen

Hi,

I’m facing this issue since last week. When I try to open a file, the blue loader takes some time to reach the right edge of the screen, and then the screen just hangs. I don’t see the file or the editor.
There is no error message at this screen either.

I mainly use Chrome, but I tried this on Safari and Brave as well. Also tried with the desktop app but its the same issue. (I’m using a 2015 Mac running Catalina)

I tried clearing the browser history, cache, and cookies, but no luck.

Also, I’m seeing this issue with all files I try to open, not just some specific ones.

(edit: it works fine for me on my mobile device - iphone 6/Chrome)

Any suggestions???

Try to open the browser console and see what errors you have there. Then try to google them to potentially find fixes or send them to the Figma support team via support@figma.com or the support request form.

So here’s a couple of screenshots to the console:


It’s some issue with the Websocket … but I don’t really know where to go from here.

Contact Figma support with these errors, they will probably be able to help.

So Figma support got back to me on this:


After some time spent on Google, I finally figured out that a SOCKS proxy was accidentally selected somehow in my network preferences>advanced>proxies

De-selecting SOCKS proxy resolved the issue for me.

this is where one can check that their websockets are working properly: https://websocketstest.com/

1 Like