Figma links always open in browser, not desktop app

I’d like Figma links to open in the Mac desktop app, but they only open in the browser. The option to “Open in App” doesn’t exist in my Preferences menu in Figma in either the browser or desktop app.

I’ve tried reinstalling the app, reloading all tabs, and restarting my Mac –– of the things recommended here:

1 Like

The “Open in App” option doesn’t exist in my preferences menu, as shown here:

Trying to figure out the solve for this as well… having the same issues as screen shot above.

I JUST started having this problem as well. I found this old thread about it, but it’s closed.

I’ve tried uninstalling and reinstalling the Figma desktop app and restarting my Macbook, but neither fixed the issue. Interestingly, when I reinstalled the desktop app, it did open my browser to log in, and then went back to the desktop app automatically upon detecting my login from my browser. Very frustrating.

Same issue here, and it’s quite annoying.
As a workaround I use https://browserosaurus.com, but would be nice to have it working out of the box

I’ve also recently begun to experience this issue. Previously, opening Figma Links from my Jira tickets would open to a browser page saying “your link will open in the app” and then focus would switch to my Desktop App. Now, it simply opens the new Figma tab in my browser, but the page doesn’t load completely, and nothing happens in Figma.

Glad that I am not alone, it started happening for me couple of weeks ago. Anybody found how to change it?

1 Like

I just found a fix! If you go to the Figma web app, then the tick box preference is available to tick. It’s not an option in the mac app! :tada:

This only seems to work once you have the page open in the browser and click on something from the Figma file, I’m not sure about the others but I’m trying to open links people have sent me (usually via teams) and they keep opening in the browser not the app :frowning: This didn’t used to happen so I’ve no idea why it is happening now

Same problem, both on iMac (Big Sur 11.6.8) and Macbook Pro (Ventura 13.1). Tried reinstalling, restarting, turning the setting off and back on — nothing helped. The menu persistently suggests I get the desktop app and doesn’t recognize that I already have it.