Enable Assets search only for enabled libraries

Since a long time ago I have noticed that Figma allows you to search all your published components within the asset window of a file. The thing is that I want to search only within the localized assets of a file and not all. All other libraries are switched off, however, I still search across every file and this is really frustrating.

I initially believed that this was a bug that would be fixed, but 1 year later I see that nothing changed. I remember that Figma used to allow its users to search within different published libraries in a file - if they wanted to, not obligingly. Anyone else having the same issue and found any solution?


I am not sure if my problem is the same but it is frustrating and confusing to our designers as well, that they see components in search for libraries the have not enabled in a file. one would expect to see results for only the libraries that have been enabled.


I totally agree. For large orgs with many libraries, this is not only unhelpful, but anti-helpful. Search should search your local file and the enabled libraries only.

Maybe instead of “Showing results from all libraries” it should be a link with text “Show results from all libraries” that only shows results when you click the link.


I just posted a question about this. I totally agree. What’s the point in toggling a library if its components still appear in the search?


Jumping in to reiterate what the others said - this feature is not only not helpful, it’s harmful. I work in a large company with dozens of different design systems scattered across various organizations, and when people are working from my design system I need them to stay there because those are the things that have been built for them. It’s a toolbox, with very specific tools in it - if a designer doesn’t find what they need I can’t have them rummaging around in their neighbor’s toolbox, right?


I totally agree with Iasonas
Too often do I pick the wrong component because it is impossible to know what library the component belongs to by looking at the “search result”. And for people not familiar with our design system it is even more confusing.

Bump #Figma?

Today I did two new things in Figma: I upgraded to a Professional plan and I started using libraries. 15 minutes later I’m reading this thread. That’s unfortunate. :disappointed:

What’s even worse is that the search results show components from read-only libraries that I have no way of removing from Libraries. Am I missing something? Shouldn’t there be a way to do that?

EDIT: Ok, I managed to at least solve part of the problem, thanks to @Gleb: to remove the file from the Libraries modal, open the file, click Share, find your name in the list (using the browser search, because there’s no filter) click the dropdown and choose Leave. That is so counterintuitive…

1 Like

Oh gosh - this a million times. It’s amazing that a library that isn’t included in my project is featured in asset search.

It’s even more unhelpful that you can’t even see where those results are coming from - so if you search on “button” and there’s fifty components called “button” from design libraries that aren’t included in this project how are you supposed to tell which is the one you need?

1 Like

Joining the bandwagon and :+1: to what everyone said in the comments. My expectation: the search in the Assets-panel only finds the published components, for the libraries that I have enabled for the file in which I’m working on. Anything else is a distraction.

@ moderators (like @Gleb ): this get help topic thread also relates to this feature request (as it’s poster, Dario commented above) : Components from unpublished library show up in search results

I posted comments there first, before I found this feature request (and found the other similar topics on this same issue).

Related to this, if multiple libraries are attached to a file, the asset search should indicate which library a component lives in. In the attached image I’ve enabled two libraries for this file, and I’m searching for a Button component. But each library has a Button, so how do I know which one belongs to which library? The only way to find out is to drag them into the file and see which system they’re in under Swap Instance.

Possible fixes: separate search results by library, show library on hover.

We have this exact same issue in our Figma.

My expectation: the search in the Assets-panel only finds the published components, for the libraries that I have enabled for the file in which I’m working on. Currently, I keep seeing published components popping up in the “Search…” results, even though I haven’t enabled the said libraries for the file. Note: these components do not show up under the “Results from all libraries” but in the same list/grid as all of the results.

Oh-kay, apparently this is not a bug, but a “feature”: Why do I get search results from Libraries that I have not included in the project? :sweat:

If you see this and also think that the way that asset panel search results now show up isn’t helpful, please vote for this feature request: Enable Assets search only for enabled libraries - #6 by Steven3 :pray:

I moved some messages and closed the related topics so the discussion is focused in this one.

1 Like

Please tell your devs that this is the desired behavior:

The search in the assets-panel should only find published components for libraries that are enabled in the file that is currently worked in.

Anything else doesn’t make any sense at all. I am working with Figma since the very beginning like 6 hours a day and know every tiny workaround, but there really is NONE for this and it is frustrating because it is probably super easy to fix and yet SO annoying.

PLEASE make sure your devs tackle this asap. This has been a problem for so long now :frowning:


This is a major annoyance for my organization. Designers often find things via the asset search function, but without the ability to filter things that are unpublished, they often grab outdated / old components that are no longer recommended for use.


You can now search only within a specific library using the Insert Component menu (Shift + I).

But that still doesn’t solve the main issue :wink:

I understand.

This is badly needed!

Re-hydrating this discussion and feature request. We’re part of a huge organization with an extremely large number of teams (each with multiple library files) and we desperately need the option to turn off the “Showing results from all libraries” feature. The whole point of having toggles for libraries is to make sure outside library assets don’t accidentally end up in our files and this “all libraries feature” completely kills the point.

1 Like