Components not updating variables?

So I have a published library with a lot of components, one of them I added a variable and published it again, but when I try to use them on my files the change isn’t added. I tried to publish it several times (tried to add simple changes like description, details just to republish that component), but still not working.


As you can see I have 3 variables, they are named right, everything is “published and up to date”.

Also I found that if I copy and paste a child from the library, it paste in a new file as detached instance.

Added more screen captures on another message because the forum isn’t letting me to add more than one :roll_eyes:


@Giselle1 Have you:

  1. Made sure you updated the file you’re working with the latest library update?
  2. There’s no conflict in the original component that’s preventing it from being published?
1 Like

What do you mean with the “latest library update?” i am not using branches and when i publish the library the updates should automatically ask if i want to update the components, it ask it to do, but they still working wrong, i have also another component that is asking me to update with an old variable that is deprecated and also i erased it. It was working OK when i did the changes, and i been having this weird problem since yesterday.

2 - No conflicts.

Here is another example of the library updating wrong or with an “old version” of it:

The update takes an old version of the component:

The actual component (PUBLISHED AND UP TO DATE)

This topic was automatically closed after 30 days. New replies are no longer allowed.