Component not changing in prototype [BUG?]

I have created a component which will change to another variant of it when I click a button but when prototyping the change is not happening. What could be the issue?

The edit button is not changing to save button

1 Like

I am having the same issue. Components that were previously transitioning to states (hover ie) are now not working correctly.

What has changed since? We upgraded to Org pricing tier.

Hello @tank666, do you know why this is happening? :slight_smile:

Did it work properly before? If so, please submit a bug report to support.

Try removing the button component’s text property. Or create and use a new component that meets the requirements of this task.

I have tried the following with no success.

• create a new component
• Reload tabs / all tabs
• Restart Figma
• Restart computer.

Could you share a link to an example file?

Got response from Figma that this is a know issue where text properties are not swapped as expected when a component is setup with both a on-click and a hover interaction. (Nested as well).

Solution: You can remove hover effect from components interaction section, nested as well.

1 Like

I am facing the same issue but I don’t even have a hover effect. what’s going on? I am just changing the orientation of a triangle when clicked on the triangle should go from horizontal pointing to downward pointing. every other clickable component is working just fine.

I’m experiencing a similar issue just not with the text changing. But I have a pagination component made out of our button component. That button component has hover states that are wired up in the parent component to appear in any prototype (I’ve tried it with “Hover” and “Mouse Enter/Leave” to get it to work). Those buttons in my pagination component have different states depending on the state of the pagination component. When I test the component, pressing the arrow button or pressing the a number button to change to the next page I have a similar problem. Basically, which ever button is pressed looses the ability to change to the state/appearance it should be when the component “changes pages”. When I use the arrow buttons, they can’t appear as “disabled” when the pagination has hit 5. When I click the numbers then they can’t appear as the blue “active” when on that page in the component. It won’t let me upload a little video demo so here’s the little prototype link:

Hey @Sarah_Lund1, I tested your prototype and I think it’s related to this post:

Could you try applying the “Reset component state” setting?

Thank you! I had not found that thread yet when I was researching my problem. That worked and it’s changing states no problem now.