Can't publish library and many components are failing to load

I’ve had a strange issue with our team library for the last couple of days. I’m getting no help from the error messages, and I can’t find any fixes in other topics.

I can’t publish any changes to the library at all. There don’t appear to be any errors with the components. The publish pop-up is also showing 60 changes when I have only made a couple changes to existing components. Hitting publish with any of the components selected shows a red error notification: “Unable to publish X changes to the Team Library”.

Meanwhile, other files using the library are showing that there are some updates, but they are for other components that haven’t been changed, and the timestamps for the changes don’t make any sense. They are showing lots of different changes at various times in the last 2 days, while I have been unable to publish. The list of components with updates doesn’t include any of the ones I’ve changed recently.

Accepting these updates doesn’t apply any changes to any of the components anyway. The “Component update available” notifcation reappears if I reload the tab, with the exact same list of (unexpected) changes.

On top of all this, I’m unable to use a lot of the components from the last publish as they are failing to load properly. Selecting them in the assets panel loads the preview window, but shows a yellow notice that the component could not be loaded. Dragging the component out of the assets panel does nothing. This is the case for about half of the components. The others work fine (albeit they can’t be updated).

Has anyone else encountered anything like this before? The lack of feedback from the system about why it’s not working is driving me nuts.

I’m not missing any fonts used in the components, which was a fix in a similar-ish thread from last year.

1 Like

Hi Paddy,
Thank you for flagging this. We appreciate you taking the time to report the problem! For visibility, our engineers have successfully released a fix for this issue!

Please refresh Figma to make sure that you are using the fixed version. If you continue to experience the issue, please let us know and we’ll flag it down for further investigation.

We apologize for any inconvenience this issue may have caused you.

Hi Celine,

Thanks for the update.

Unfortunately the problem is still happening for me and getting worse. I have triple checked I’m on the latest version and have closed, reopened and reloaded everything.

I still can’t publish any changes, and there’s absolutely no feedback as to why. It has now been over a week since we’ve been able to publish a component or style update.

What’s getting worse is now the ‘Updates available’ window is showing ‘new’ style updates with timestamps from last year, before they were even created at all.

It seems like our main library has been completely corrupted somehow. It thinks all components have updates when they don’t, the update timestamps make no sense, and nothing will publish under any circumstances.

Next week I’m going to have to try migrating some styles and components to a new library to see if that helps. That’s a huge pain and I’m expecting it will not be easy to reconnect all the component instance relationships to a new library.

Hi Paddy,
Thank you for the details! Sorry to hear you’re still having trouble. After investigating internally, our engineering team has been working on a new fix today. It’d be great that our team have a deeper look into your files and issues to investigate further. This will also help us to see if there are any other bugs around this.
I’ve gone ahead to set up a ticket for you. For your reference, the ticket number is #828245. Thank you for your understanding!

1 Like

I’m having the exact same problem with my library - components won’t publish, and some (but not all) don’t appear in instances using library components.

Same here, started experiencing this 1h ago. I made a change to a component with two variants and it won’t let me publish it.

My team has been experiencing an inability to publish library assets – I have tested with an empty project file with absolutely no connected libraries and a simple, two sentence, default font, component with an autolayout…publishing fails.

Same here. The problems started on Friday when trying to publish components with variants. Publishing a duplicated version of the component (making it a new master component) worked so nothing seems wrong with the component itself. Don’t know if a fix as been made, but this morning my library worked again. I’m just worried that it’s going to become unstable again since i’m building a lot of components at the moment for my design system.

The error message says to reload the page/tab, but that doesn’t fix it. Neither does restarting Figma or using the web version.

It’s three days later and publishing is still not working no matter what I do, no matter which file I’m using, no matter how simple or complex the component library is.

Hi all, sorry to hear you are still having issues! I have escalated internally to our team.
Please refresh your browser and/or desktop app to see if this can help.
If not, please contact our support team (with a copy of your file, if you are able to) here: https://help.figma.com/hc/en-us/requests/new. This will help us to investigate / identify where the issue might be occurring. Thank you.

1 Like

Update: as of today, it’s failing with a different error message:

“Publishing failed: Please reload the page to publish.”

It also takes much longer to fail than before, but it still invariably fails. The problem with lots of unchanged components showing as changed also persists. It’s a different number today, though: 18 instead of 60.

Reloading the page or restarting the desktop app don’t help.

also having issues, I keep having to close and re open Figma, no errors just won’t give me the notification
also for some reason random things keep happening, right now my buttons, despite not touching them, has decided to rest the text on every single BUTTON component… which has caused a lot of issues you can imagine

Hi @paddy_duke_valla, thank for these details. I checked in our backend that our technical support team is working on your issue, and wait for your reply. Please check your inbox, thank you!

I had this issue as well, I found out that the problem was the following. I accidentally made a component loop by adding a “child” component within the parent that was also used in the child component. After removing that it worked again.

I am still having this issue and cannot publish, can someone please help?

I am facing the same issue, I have the master/parent and child components in the same file, and I can see the child component, but the file isn’t loading/displaying the master component.

Is this still being worked on? Facing issues and not being able to proceed with work.

Hey @Aarjav_Pandya2 , the issue has been solved. Please try to refresh your browser / desktop app. Still, if you are still having issues, please reach out directly to the support team with a copy of your file, so we can investigate further here: https://help.figma.com/hc/en-us/requests/new

Be sure to use your Figma account email, include a link to the file, and share it with support-share@figma.com so they can take a closer look.