Windows11 fonts problem

i have the exact same problem: with win11 the fonts are not syncing with Figma. after every reboot of the pc i have to reinstall all my fonts i’m using in Figma. then they are recognized again. this happens in the browser AND on the app.
i tried to delete all of the fonts, reinstalling the Figma font service, trying without the font service just in the app… the problem persists. the font itself is not the problem because on windows10 and on mac i can use it without a problem.

1 Like

Same issue for me

Same! I have to install all my project fonts each time. They disappear after restart. Figma is the only app with this issue. Has anyone found a solution yet?
I’ve tried using browser with font agent, using a manager like fontbase, and playing around with firewall settings. Is it a system permission issue?

Same issue for me. Everytime I reset my Windows 11 computer I have to reinstall any custom fonts before it can work.

Same for me! I hope someone comes with a solution for this, because what a nightmare to work like this

Same issue here. I have the font service installed. I tried on both the browser and desktop app and it says I have no fonts found that are installed by me. I really hope there’s a solution for this soon.

Hi everyone,
Thanks for flagging this, and sorry for the trouble. As a workaround, please clear out the desktop app cache on Windows by following these steps:

Run a command line from the Start menu.

  1. Close the Figma desktop app.
  2. Open the Start menu and paste the %APPDATA%\\Figma command. Press the Enter key to submit.
  3. In the window, delete the DesktopProfile folder.
  4. Launch the Figma desktop app again.

Can you also please try reinstalling the font itself and seeing if that works?
If that doesn’t work, please reach out to the support team here: https://help.figma.com/hc/en-us/requests/new Our technical specialists can investigate it further.

(For your information, if you have issue with FontBase, currently, we don’t have official support for external font managers, including FontBase.

For the best experience, we recommend directly installing your fonts. However, for more specific guidance or support related to FontBase, it would be beneficial to contact their customer service team. They can provide more detailed assistance tailored to their application.) I hope this helps!

Hi, any solution for the web app when used on a windows 11 system?

Same problem here. Windows 11. Tried reinstall Figma and Figma Agent apps. Also tried to delete Desktop and DesktopProfile folders in %APPDATA%\Figma. This problem is very annoying because i have to reinstall every font evey time i reboot my PC. Web version also don’t see my fonts but i have them all installed on my PC. Any workarounds / solutions?

Ok, so I seem to have stumbled on a solution for me. For some reason, the “installed by you” tab in the font selector always appears empty. The installed font appears in the “all fonts” tab. It’s odd that it appears in the “all fonts” tab since the installed fonts aren’t system fonts.

On Windows, it would be better if fonts detected in the C:/Windows/Fonts appeared in the “installed by you folder” since those are local fonts and not Figma/cloud fonts. On Mac, user-installed fonts appear fine in the “installed by you” tab. Don’t know why it doesn’t work the same way on Windows 11.

Tried all these things. Same issue. Using fontbase. Every other app works just fine and shows all the fonts Figma won’t. Can’t even work on a project. Needs a fix ASAP.

Can you try going to C:/Windows/Fonts and see if you see shortcuts to your activated fonts there from Font Base? I use Font Base too, and it works. The fonts are just located in the “all fonts” tab instead of the “installed by you” tab in Figma.

Another thing I did was I moved my root font directory that’s in Font Base to C:/FontBase. I used to have it somewhere else, but I read in some threads that the Figma was having a hard time reading long paths.