Figma Support Forum

Windows pinch zoom on figma is too fast (HDPI drivers)

Try pinch zooming in a Figma with a windows laptop with the usual Hi DPI drivers.

It zooms in a crazy amount; and out a crazy amount. The only way I can zoom on windows laptop is ctrl + scroll, but this is cumbersome.

Demo:

Pls fix. This doesn’t happen in any other windows application I have

13 Likes

Have the exact same issue here. It’s making Figma very difficult to use.

Agree, this makes viewport navigation on a laptop very clunky

Yeah, I have exactly the same problem. Why is this so hard to fix? This has been persisting for months now and nothing has changed! And this problem does not occur on Mac OS, so why is it not possible for Windows? This really makes the user experience of Figma so much worse.

Hi, I’m having problem with the pinch to zoom in/out gesture.

I’ve just built my pc and installing windows 10. Since the trackpad is so helpful when I’m using my macbook pro, I’ve decided to use Apple Magic Trackpad on my windows 10. I’ve installed the driver called ‘mac-precision-touchpad’, most of the gesture works just fine except the pinch to zoom. It’s so bouncy and the sensitivity extremely high. I’ve already play around with the touchpad settings but nothing works. So I wonder if there’s anyone here has the same situation with me and already solved the problem?

Cheers.

so from March there are still no follow up about this?

Yeah I have EXACLTY the same problem! I have a windows PC and bought the Apple Magic Trackpad specifically for doing design work on my computer. On all other prototyping software I’ve used (such as Framer, ProtoPie and Quant-UX) the trackpad works perfectly when using pinch to zoom! Figma is the only one that has a problem with pinch to zoom!

I have the same issue as well and it’s ruining my figma experience. When I pinch to zoom, it does it so fast with about 1000% it also affects my presentations to stakeholders and now I’ve told most of my clients that adobe xd is a better experience and alternative moving forward. I don’t know why figma can’t fix something this simple but really problematic for designers on windows pc using the trackpad instead of mouse.

I guess because number of people like us who use Windows and Magic Trackpad really less. One of the cons for being minority :cry:

I just started using Windows recently as well, and I’m having the same issue which almost drove me crazy after having had a great experience using Figma on a MacBook. Very disappointing :disappointed:

I have the same happening with Microsoft Surface Book touchpad. Figma please fix this.

I also have the same problem as a temporary solution I use Ctrl/± to zoom.

1 Like

I have the same issue. Using a magic trackpad 2 with a wired connection. Can scroll without any issues but zooming is way too fast and jittery, in both the desktop and web applications. Please fix this issue.

2 Likes

Just got a new Windows laptop and downloaded Figma to continue working and was very disheartened to find out about this issue with the touchpad, I don’t understand why its not working smoothly like in Macbook (previous laptop where I used desktop Figma) and why this hasn’t been fixed yet when the community has been posting about it in the forums for quite some time now…

I am having the same issue on both my Windows laptops (SurfaceBook 2015 & Razer Pro 17 2021).

Figma please fix this.

Hello! I’m working on fixing this. Can you DM me your Figma account email address? I’ll enable a fix for your account so we can test if the fix working properly.

2 Likes

Alt + Ctrl + 0

Hello
I have the same problem, but I can’t DM you (I have no message button nor here nor in your profile)(maybe because I am a newbie).
Can you DM me instead?

We’ve rolled out the fix for everyone. Please restart/reload your Figma tabs or desktop app!

1 Like

I’m still experiencing the same issue

2 Likes