Why won't "fix position on scroll" appear?

I have Frame A, which contains Frame B. Basically, Frame B is a header and Frame A is the entire webpage. I want the header (Frame B) to remain fixed as the user scrolls down the “webpage” (Frame A).

I have vertical scrolling enabled for Frame A, but no matter what I do I cannot get “fix position when scrolling” to show up for Frame B, and in the prototype as I scroll, Frame B scrolls up too and disappears.

I have tried changing the scrolling behavior of Frame B to no scroll and vertical scrolling, neither of which work. Frame B was a component, so I detached the instance to make it simply a frame, and that didn’t work either. I feel like in the past I’ve been able to successfully do this so I’m not sure why it’s so hard now.

What can I do to achieve this?

Also design suggestion for Figma; can you make “fix position when scrolling” appear at all times and simply be disabled rather than disappearing entirely from the UI? If it had a tooltip explaining the issue when disabled this would be even better. It’s hard to debug when you’re not sure if the element will even appear or not.

Thanks for the help!

1 Like

When you define what can scroll or not, the layers panel will have sections for scroll and fixed. This would be a good spot to check where things are dropping since I imagine if B is wrapped in A and A is fixed then B will take on the attribute from A.

Screen Shot 2022-08-23 at 2.39.25 PM

1 Like

Thank you, that’s a good tip! As I mentioned, A has scrolling enabled. In the side panel I can see that nothing in the frame (or even in the entire filed) is fixed

Do you have autolayout enabled for frame A? Autolayout frames can’t contain fixed objects. With the new position absolute they can, see below.

If so you have to wrap A inside another frame, let’s call it C, which you enable scrolling for, then move B out of A and into C. Now B can be fixed.

Or you can make B’s position absolute, then the option to fix it will turn up.

1 Like

Both of these suggestions worked!! Thank you so much!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.