🚨 Variables: Deleted collections and modes don't disappear

When Variables was released I created some collections for testing. Since then I settled on a final version but the old deleted collections still appear in the page/layer selection on the right panel. The same is happening to deleted modes.

9 Likes


See example here.

1 Like

i have the same problem, is there any solution for this?

1 Like

Same problem without any solution.

1 Like

I encountered a similar situation, I had a Collection with some color, after delete it, it still visible in the layer panel, but there is no missing color in the Selection Colors… However after a bit check up, I did find some merged shape layers still have the old variable, although they don’t appear as missing in the outer Selection Colors, delete them and the old Collection finally gone.

3 Likes

I think it’s a serious problem. I think it would be good if Figma could solve it quickly.

3 Likes

This is definitely creating problems for me. Please fix this!

2 Likes

I have the same problem. Any solution to fix it?

1 Like

I have the same problem!! Please fix this!

1 Like

Same here, would be great to resolve this.

This is really annoying. I have random text variables that I cannot get rid of - even thought I deleted them - they just keep showing up as options to select even though they don’t exist.

1 Like

We are having similar issues. Please fix this.

I’m also having this problem, and especially in the combination with my shared library and local variables. So, please fix this asap, thx.

Any head-ups on this ?
This is an issue !
Even by creating a new theme (over the deleted ‘spot’), it still show unavailable.

I have the same issue. I already reached out to the Figma support team. The issue was not resolved. I would like to hear something from Figma within this threat. For us it’s a serious issue, now we’re building a theming layer. Please fix this!

1 Like

With the limited variable mode of 4.
I need 2, that fine.
But, with that bug, For some collection, I can’t do my work anymore, as 3 spot a taken by those deleted.

I had a similar issue and found that I was still referencing some variables & modes from a deleted collection. Once I broke or re-assigned all those connections, the deleted collection and modes finally went away.

Hey all, PM for variables here. This is caused by variables still being present in the file from the deleted collections. One easy way to fix this is to detach deleted variables in the file. There’s a quick command for this as well:
image
You will have to run this on every page of your file. If you still see this persisting, close the file for a couple minutes so the garbage collection routine can run. If you see it still persisting beyond that, send me a ping at jake@figma.com so I can have the team look into it.

3 Likes

Detaching deleted variables didn’t work for me. I even deleted all frames from the file as a test, but still the deleted collection appear.

3 Likes


As you can see in the video. I’m not using any deleted variables in both libraries.
The deleted variable collection(Latitude components) still appears and some modes on the active collection(Latitude foundation) are grayed out and disabled.

1 Like