Toggling a specific Layout Grid in the Inspector shouldn't Toggle ALL grids

  1. Describe the problem your experiencing and how your idea helps solve this
    When I use the :eye: icon to show or hide a Layout Grid, I believe this should only show or hide the Layout Grid on the selected Frame.

Currently it shows or hides Layout Grids globally (i.e. functions the same as CTRL + G) which I don’t feel is correct. In fact I think it’s a little limiting given you can have multiple Frames within a master Frame each with their own Layout Grid (the result is you have a lot of overlapping grids and it’s hard to distinguish one from another).

Personally I think the global control for showing and hiding Layout Grids (CTRL + G) is separate to showing and hiding individual Layout Grids.

For example, let’s say I have 3 x Layout Grids applied within a Frame and some nested Frames. And let’s call the Layout Grids: Grid A, Grid B and Grid C.

The first thing I want to be able to do is hide Grid A and Grid C and leave Grid B visible.

The second thing I expect is for the global control for Hide/Show Layout Grids to respect the selections above (almost like how Showing and Hiding Rulers respects the Rules I’ve already drawn).

  1. Add as much context as possible (screenshots, Figma files, mockups, etc.)
    Here’s a gif which sort of shows what I’m referring to:
    20220203-1424

  2. Ask questions to bring the community into the conversation
    (e.g. Does anyone else experience this? Is anyone using a plugin or workaround to help solve this?, etc.

2 Likes

I have exactly the same problem. I cannot toggle individual grids. Hiding one in the inspector panel hides all.

1 Like

:+1: Our team is starting to work with grids but the way the toggle “works” (or I’d say “doesn’t work” as it seems more like a bug than a feature) and this is annoying.

Is there hidden functionality to allow grids to work in a way that makes sense? Why does toggling one frame turn EVERYTHING on?
If that’s an expectation it should be somewhere else, nothing else in Figma behaves this way. Turning on a fill for a frame doesn’t enable all hidden fills. Why do grids do this? :angry:

I experience this as well. It’s very frustrating.

1 Like

+1! Seems like a bug more than a feature!

Having a global on / off is great, but it should respect how they’ve been individually set on components.

Very irritating.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.