Text jumps up/down within bounding box when selected - intermittent issue

This has been frustrating me for a while now so I thought I’d finally get around to posting!

When editing a Figma file, if I select a text element the text can jump up/down within it’s bounding box. The bounding box does not change height, it’s just how the text sits within it that changes.

So if you have two artboards with the same header + heading/text for example and select those elements on one of the artboards, the text can move up. So moving between each the text won’t align. So you need to through everything and click so it all matches.

Not ideal but everything is consistent again at least …until a few days later when the opposite happens and the text moves back down to how it was.

I thought this was down to multiple users and maybe different versions of the same font file but last night I left something, no one else has been in the file but I’m clicking stuff and the text is moving around again. So can’t be down to the font file or another user.

All the typography is setup and saved as text styles so are consistent and haven’t been edited at all.

Also in the attached example, this is a component that has not been edited so it really has no reason for the position to change? It’s almost like Figma is interpreting how the text aligns/where it’s baseline at different times?

If anyone has encountered this issue or has a way to fix I’d greatly appreciate it! :slight_smile:

1 Like

Thanks that helped resolve the issue!

As I had a lot of ‘saved’ font settings I just had to set up type for each then run the steps in that linked post. Maybe “Regenerate All Instances” would’ve saved me doing that but didn’t know what else it’d affect so opted for the first option.

Very strange it occurred when one one else accessed the file - and I even asked for the font file they were using to install that so we ‘matched’ as well just incase.

Ah well, just one of those quirks I guess. Thanks again!

What’s ridiculous is, I’ve just fixed all that. Gone for lunch, come back and opened the file and now when I click anything it’s flipping back to how it was :weary:

No one else has been in the file at all and I’m using the same laptop etc. So strange!

What’s weird is, the ‘reset’ this time is the opposite. So really not sure what’s happening. Only me in the file yet it keeps switching the spacing of the same one font (Graphik and only one weight).

I have the same issue too! Did you find a solution? I was abled to fix it by clearing caches but unfortunately it doesn’t work anymore.

Hey @Ornella1! The reply from @tank666 to ‘reset’ the position worked but I never found an actual fix for it.

I haven’t noticed it since but maybe because that project finished and I’ve not worked collab on current stuff. So unsure if it was 2 users causing it or just a certain font :man_shrugging: