Space(s) added when copying a text from website on Windows

Hi i’m mainly do my copy and paste text on Figma. Yesterday I cam with this annoying “bug” that it keeps adding space below the text when you copy something from the net. See image below, how do I eliminate this? All of my settings sre correct from my previous works.

I hope you can help me :frowning:

1 Like

Hi can I ask something having a hard time dealing with this issue how to fix this issue on Figma where when you copy something from a certain website (ex: google spreadsheet) it added space below the text (see image below)


1 Like

did you find the solution for this issue?

image explain in the Figma link below:

since few days ago, on my computer it has this problem when i copy text from teams conversition paste in Figma(copy from website also has this bug). i tried copy from website text field and it’s all ok.

I tried from my Apple device and everything is ok.
I remember there was the same problem in the past. but I think it was fixed by Figma team

My system is Windows 11 pro

Hey there, thank you for flagging this to us!

We’re passing this onto our team to try to reproduce and work on a fix. We can confirm that this bug does not seem to happen on Mac.

Can you confirm that you’re only seeing this issue when copy and pasting text on your Windows 11 device?

hey! i also have such problem. it adds even more than just 2 line breaks when pasting from Word-document.

windows 10

1 Like

I agree with this question - I have the same problem, it probably arose about 2 weeks ago. When copying text, space is added. Windows 10

1 Like

Hello, I am trying to copy/paste text, from any basic word software to Figma and FigJam canvas, with proper formatting. But everything went chaotic after my laptop reset.

How it worked before the laptop reset

When I copied a paragraph from any software, it pasted exactly in the format it was copied.

How it works now

When I copy a paragraph from the same softwares, it pastes the text as if I copied it from a protected PDF document (with inconsistent formatting, many spaces and A LOT of line breaks).
I tried many text softwares and apps, but it only happens in Figma and FigJam. Never saw anything like this in years on this app, lost a lot of energy formatting everything.

How do I fix this please??

Screenshots (of the copy/paste)


Additional info :

  • I tried Ctrl+C / Ctrl V, and also Ctrl+C / Ctrl+Shift+V, but the same thing happens for both.
  • I tried softwares like Word, OpenOffice, even random txts softwares, in many extensions (.doc, .docx, .odt…) but the same thing happens.
1 Like

This started happening to me in December. Copying anything will result in adding a space above the text and 2-3 extra lines below it. Very annoying and slowing down my work. Is there a fix coming?

1 Like

adding: Windows 11

Try pasting the text into a plain text editor first to remove any formatting. Then, copy it from the text editor and paste it into Figma. Moreover, ensure that your text box in Figma doesn’t have excessive line height or padding settings. Adjusting these settings can help eliminate unwanted space.

Thanks for the workaround, @stammeredads!

UPDATE: Our team has been able to reproduce and are proactively working on a fix! We’ll provide any further updates on its progress as soon as we hear back from the team.


This issue is also happening on my MacBook Pro (Sonoma 14.2). Figma is up to date. @dvaliao

When copying text from a document, extra paragraph characters are inserted

hey! The same problem on imac, Sonoma 14.2. Help us please%)

Hi @Katie16

This question has been asked before, it’s a bug which has no solution yet:

I have Mac and unfortunately the same thing is happening to me for almost a week :sob:
Figma is up to date.

it does happen on Mac

Hey All, thank you for letting us know that it’s happening on Mac too. We’ll pass this along to the team as they continue to work on the fix.

1 Like

When copying and pasting content from Word or Excel, an issue persists where a blank space of 5-10 lines is added before and after the content. This problem has been ongoing for weeks despite updating and reinstalling Figma. Notably, the issue doesn’t occur when copying content from a browser or online Word/Excel file. This concern is prevalent among my colleagues who are also using MAC.