Smart Animation Not Working

I created an loading circle component, and placed it in my design. When I start the prototype from that flow, nothing happens, even though I have the component variants set with smart animate. I was following a tutorial and thought I did it perfectly. I read that this issue is possibly related to the latest update in Figma. Has anyone experienced this

I need to know how you’ve made the animation to be able to answer this. Can you explain or share a screenshot or design file?

1 Like

Hi Avokadomos! Thank you for your reply.


I have these three states, and it set to smart animate from 1 to 2, 2 to 3, and then 3 back to 1. But when I run the prototype, it should look like it’s spinning but it doesn’t do anything. Please let me know if you have a solution or if you need more info from me, much appreciated!

I don’t see anything wrong in the screenshot. Make sure you’ve placed it as a component in your frame, and not just one of the variants.

I made another prototype that you can inspect in Figma:

1 Like

That looks great. Yes, I believe I am using it as a component in my frame. It was dragged from the assets on the left.

Try my component and see if it works for you, and check if there are discrepancies between our designs. You can also try pressing R in presentation mode to restart the presentation. It might trigger the animation to start.

If you still can’t figure it out, please share your design file so that I can have a look at it.

Looking at your component vs mine helped. I see that my problem was I was setting the instance to be rotated instead of the actual ellipse itself. Everything seems to be working now, thank you so much!

I’m glad you figured it out! Consider clicking the checkbox under my previous comment to mark your topic as solved. Have a nice day!

1 Like