Pinch-to-zoom unreliable

This is happening to me too. Sometimes closing and reopening Figma fixes it, sometimes not. Other times using the keyboard shortcut to zoom fixes it. Really frustrating.

1 Like

Also happens to me sometimes.

Randomly found that click with two fingers to open context menu (with or without holding command) could fix it. (Probably quicker than restarting app or check/uncheck MacOS setting :joy:)

5 Likes

It happens more and more for me. But it affect all my design tools (Figma, Adobe XD, Sketch, Framer, Miro…) the pinch stop working randomly on all of my tools together. I reinstalled MacOS and everything were fine until… I installed Figma. Thank you Figma :slight_smile: ! When I set the trackpad On/OFF sometimes it solve the issue but sometimes it doesn’t. I have to On/OFF the pinch gesture many times. This is very annoying !

1 Like

Same issue here. Figma is getting so buggy it’s starting to feel like Photoshop.

Trackpad completely stops working. This happens in no other app. It’s happened six times in the last hour. Sometimes switching tabs in Figma fixes it, but most of the time I have to restart Figma. Note that the Figma tabs accept clicks, but the Figma page does not. Hard to blame that on Apple.

Don’t have a solid repro, but it seems to happen after deselecting a deeply nested selection.

2021 MacBook Pro M1 Max running MacOS 12.2.1

Happening to me as well, M1 MacBook Air.
Pinch-to-zoom working in other Mac apps perfectly fine.

1 Like

I’m also running into this problem. Macbook pro 2016. One workaround that fixed it was using command+(+/-) to zoom in and out and it started working again. Better than closing everything out - looking forward to a permanent fix!

2 Likes

Happens to me too occasionally. I find that putting my Mac into and out of sleep quickly is the most convenient way to fix it.

2 Likes

Thanks Joey - magic solution! Tedious, sure. But it worked!

macOS Setting → Trackpad → Pinch to Zoom → Change from enabled, to disabled, then back to enabled will fix it.

That worked for me too. Thank you :heart_eyes:

1 Like

Regular frustrating problem for me too, multiple times a day and fairly random.

3 Likes

Also struggling with this issue unfortunately. Disable/Enable Pinch to Zoom works well for me but can’t wait for this bug to be fixed!

2 Likes

I’m also having the same issue. Would be amazing to have a fix, its definitely an obstacle to getting work done.

2 Likes

I experience this issue almost daily with both my rechargeable trackpad and built-in trackpad. MacOS 12.3.1. It’s such a pain, I can Zoom to the level of granularity that I need unless I use Command +, which uses a stepped system.

Please address this Figma team!

2 Likes

I’m on an M1 MBP 14". Experience this issue frequently throughout the day. It eventually either resolves itself on its own after some time, or I need to turn my trackpad off and back on again (i use an external magic trackpad).

1 Like

I have this issue now on a daily basis, and i’m wasting serious time with this… sometimes it takes minutes to get back, or I can restart the whole stuff, but this is ridicolous… Figma, please fix this!

1 Like

It’s getting worse. Now I encounter this issue every day.

1 Like

On a 16-inch MBP M1 Pro and running into this at least once or twice a day. Best fix I’ve found is disabling pinch-to-zoom in system preferences and then re-enabling. Would love to see a fix for this soon. It seems like a small thing but when you’re in flow it can be jarring.

Not really a solution, but if you “Figma > check for updates” the problem is solved for a while (some times you need to do it 2 times). But 3 times in one hour is really enough.

Please fix this @ Figma! :face_exhaling:

Same issue intermittently

1 Like

This issue is happening again on all my figma files.

1 Like