Local fonts are suddenly ignored

I’ve been running into the same issue as this below:

On Mac( Apple Silicon OS 14.4 ) w/ Figma 116.17.11

I tried every solution that mentioned in the topic above.
All other apps like Adobe recognize the fonts the same as before.
also I have not changed anything like machine settings or so. One thing that changed recently is just the Figma update.

It’s been blocking my work and making me insane!
does anyone have a solution?

Figma on my sub-machine ( MacBook, Intel OS 14.4 ) was still ver 116.16.13, and it worked properly

Try reinstalling the Figma Font Helper app Figma Downloads | Web Design App for Desktops & Mobile

Thank you but I assume it does not help for the desktop app…

Your assumption is incorrect

Okay, thank you for that. is it incorrect as well?

So did you try installing it or not?

It says “not required” but that doesn’t mean you shouldn’t try. It might help if the font installer that comes with the desktop app by default malfunctions.

Yes I tried but did not work.