Figma Support Forum

Layout grids not showing

Does anyone have an issue with layout grids not showing? It happened with 2 of my recent projects.

I set the grid up, use it across multiple frames on a page.
At first the grid works just fine but at some point they just cease to display.

Ctrl+G doesn’t work at all (as is going to the top “View” menu). This happens both on the desktop app and in the browser.

1 Like

Has anyone responded to you yet about this? I am having the same issue.

Nope, none at all.

Also having this problem. Sometimes if more than one wireframe is being used, the grids will only show on one of the frames and not the one that I have selected.

We are also having the same problem with some of the icons we have made. No idea why this is happening.

Maybe this will help someone:

Yesterday it worked, today it’s not. I guess it’s a bug.

There are a couple of reasons why a layout grid may not be showing:
https://help.figma.com/hc/en-us/articles/360040450513-Create-layout-grids-with-grids-columns-and-rows#Why_aren’t_my_layout_grids_showing?

If you think this is a bug, please report it to support: Submit a request – Figma

1 Like

Same issue and the “reasons why the grid may not be showing” assume a certain ignorance on the part of the end users. Never a good opening posture and definitely a bad sole solution.

See this video for some grid weirdness.

In this video it’s clear that you have some artefacts on the screen, this is a GPU-related issue that usually occurs on the per-file basis. You can copy-paste all your work into a new file from the corrupted one and it probably will be ok.

1 Like

:point_up_2: Nailed it. Here was my issue and what I did:

  1. Copied all contents to new file (as per Gleb’s comment)

  2. No fix.

  3. Googled “figma gpu” and found a Mac-specific suggestion to disable auto-switching (which means GPU will now always be in use). As mine had always been disabled I wouldn’t have thought of it…

  4. …but there it was, enabled.

  5. Disabled auto-switch on GPU.

  6. Restarted Figma app and…

  7. Voila.

In case it’s a GPU issue for anyone else.
Thank you, @Gleb

1 Like

Hey everyone,

I was also having the same issue and stuck because it wasn’t my GPU. However, I did realize when I had rotated my frame. the grid layout disappears. I would say try to make sure that your frame itself (not the contents within) are at 0 degrees.

Let me know if this worked for you! I’d love to know @goushiii on instagram

2 Likes