Large PDF exports even with compression plugins?

I’ve used many programs/apps and I find that Figma’s PDF exports are always so large—even after using plugins to compress them.

Example: Two page PDF document with only text, simple svgs icons, and two colours. No raster images, gradients, or effects. Super basic document.

  • Figma export 9.5MB
  • TinyImage compression 2.2MB
  • compression 2.2MB

I would expect this PDF to be no larger than 1MB in the first place. What is going on here?

The only possible factor I can imagine is the maybe the canvas size (1130x1600px), but I doubt it because everything in the PDF export are text/vectors. Any help?


Hey there @Kayeish, thanks for the feedback! We definitely know that our PDF exports could use a little work especially when it comes to optimizing their size. Some users have reported that using 3rd party tools outside of Figma have helped when plugins aren’t quite enough. For example if you’re on a Mac, you could open in Preview and then export again as a PDF to further cut down on size.

I know this probably isn’t ideal, but hope this helps. :slight_smile:

Oh one other thing you could check within your file is to make sure your svg icons are flattened or as simple as possible.

@Josh Thanks for the response.

I’ve used Preview and its Reduce File Size export and it’s still 2.8MB. I’ve used other third-party apps (Adobe) and none of them can get me lower than 2MB. This is actually quite an issue because of file upload restrictions are often set at 2MB for documents.

Do you know if the Figma team are actively working to resolve this?


Ah bummer that the workarounds aren’t helping in this instance. : /
PDF improvements aren’t currently prioritized but I’m happy to pass this feedback along to the team. Also I’d be happy to take a look at the file (if you’re able to share it) and see if I can offer any other suggestions to reduce the size.

1 Like

That’d be great, let me know how best to send to you for suggestions.

Feel free to PM me the file or post here in this thread. :slight_smile:

You can use our plugin, we do not export vectors and text as images, so the size should be significantly smaller.
However, we have not implemented any effects yet, like shadows…

1 Like

Thanks for the recommendation. While the PDF is very small with your plugin (53KB), the formatting is all messed up—thus making it unusable.

1 Like

The formatting should not be incorrect.
However, we cannot currently access the local fonts, so this could be the cause. You would have to define the missing fonts under “Fonts”.
Could you send me an example to test?

1 Like

@Miek I’m using Space Grotesk, which is natively available in Figma and not a local font. The formatting is all messed up, so I believe it’s an issue on your plugin end.

1 Like

Thanks for the tip, yes there are problems with the “Space Grotesk” font, unfortunately it is not recognised correctly.

Cool. Lemme know if you’ve fixed it and I can try again. Would love to have a better compression PDF plugin.

New version is online

1 Like

I tried the MKitPdf and I was able to compress my pdf from 1.3 MB to 26 KB. I struggled so much to do this! Thank you so much :slight_smile:

1 Like

@josh SO bummed to hear that dealing with PDF size is not a priority for Figma. It is a huge issue for us and our clients. We need PDFs to be 25mb so clients can email them and Figma PDFs, even compressed, are consistently over that size for most of our projects. Our clients need PDFs for legal reviews.


It’s too bad Figma isn’t working on this problem. I too have encountered that files saved by Figma cannot be mailed. Even though they don’t contain any bitmap graphics at all


@Josh Seeing that other users (here and in other threads) are having the same issue, is there any way to raise this higher on the dev’s list of to-dos?


Same problem here @Miek . Resolving this problem would enable our organisation using Figma for social media (LinkedIn Pdf). :slight_smile:

I have a problem with the ‘Lato’ font, I get text wrap, can you do something about it? I’ll buy you a coffee. Even more!

Please send me a Figma file(link) with the problem.