Interactions no longer working after creating component set from pre-prototyped frames

I designed and set up interactions for a horizontal scrolling section of a webpage before turning it into a component set. It has a timed horizontal 5-second scroll and any item within the frame you click on will be scrolled to.

Before component-izing the frames, I dropped in the “starting point” frame, which worked like a charm on my page. After I created the component set from the frames, the Prototype view still shows the many interactions I added, but none of them are working.

Even the 5-second timed scroll interaction I added simply isn’t going. It’s as if creating the component set shadow-deleted all my interactions while the UI is telling me they’re still there.

I’m at my wits end; I’ve tried everything I can think of and nothing is working.

This is a screenshot of the available interactions within the prototype presentation view. None of the interactions I have set up are showing up in the prototype.

Alright, I finally solved it.

All of my interactions had been Click → Navigate to: [Frame].

Since creating a component set technically deleted all the “frames” and instead turned them into variants of the same component, those Navigate to: [Frame] interactions weren’t being recognized by Figma and became null.

I had to manually change every interaction to Change to: [Variant] instead. It’d be nice if Figma automatically converted all of those interactions when creating a component set.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.