How to remove cookie banner from embedded prototypes?

Thank you! Please let us know if you guys have any updates.

@dvaliao Hey, has there been any progress with this?

I’m afraid our product team sill needs more information to replicate the issue properly. Do you keep seeing like you shared?

Hi, yes still experiencing the issue as I shared.To replicate. 1. Open a browser session that you are not signed into Figma with 2. Embed a Figma prototype on a web page. 3. You will see that the cookies popup appears. 4. Click any option on the popup which will make it go away. 5. Click anywhere on the page outside of the prototype 6. Interact with the prototype again and the cookie popup will re-appear

1 Like

I am having the same issue in Firefox with prototypes embedded on Lyssna (UsabilityHub). Every time I open a prototype via Lyssna in Firefox on mobile, I get a cookie popup even if I already rejected cookies before (for the same or another prototype).

Device: Mobile, Samsung Galaxy S10e, Android 12 with One UI version 4.1
Browser: Firefox 124.2.0 (Build #2016012559). In Google Chrome the popup does not appear.
Signed in to No (and not signed in on Chrome either, where I didn’t get the popup, so that isn’t the determining factor)

Edit: I’m even getting TWO popups each time, so after I press Reject, the popup re-appears and I have to dismiss it a second time. This happens consistently.

Checked our prototypes and they no longer have Accept Cookie banner.

I’m also getting reappearing cookie banners every single time Figma embeds load, especially when embedding them into desktop apps like Notion or Pitch.

MacBook Air Apple M1, macOS 14.4 (23E214)

Thanks for sharing the details! I passed the information onto our internal team. Unfortunately, there isn’t a quick solution at the moment. We will let you know once we have any updates.


I just wanted to follow up on this thread as I’m still experiencing the same issue. The cookie consent banner continues to appear in my prototypes.

@y_toku Could you please provide an update on this matter? Has there been any progress in finding a solution to remove or disable the cookie consent banner in Figma prototypes? Many users, including myself, would greatly appreciate any insights or workarounds you can offer.

Hi all, I actually stopped seeing the banner for a while but now it’s back. Would love some updates on when / how this issue can be fixed. If you would like a walkthrough on the site where this is happening so you can see the issue in action, happy to do that.

Thank you!

Same here

When im logged in there is no cookie banner, when logged out cookie banner is back and comes back after every refresh of the page where the view is embedded in, even when clicked on allow.

users of the my website allows get the banner on the embedded element. ( no accounts )

tried edge and chrome brouwser, both with same outcome.
tried on private workspace and company workspace, both with same outcome.

Maybe if you try to reproduce, try loggin out of your account, maybe that might give you the option to reproduce it.


users of the my website allways get the banner on the embedded element.
sorry typo

Hi there,

Thanks for flagging. If you keep seeing the banner, could you submit a bug report along this article?

We’re still struggling to replicate this issue on our end.

Thanks for your understanding!

Hi @y_toku would like to arrange a call where the bug can be demonstrated or provide a location/email address where a recording of the behaviour can be sent to?

I think it’s clear from the amount of people experiencing the described behaviour that it does exist and is a bug. Unless of course you confirm that the behaviour is by design.

This thread seems to be going in circles and I think there has been a lot of information provided to accurately detail the steps and conditions to re-produce.

I think we all want the same outcome so I’m happy to demonstrate the behaviour to you or the development team.

Let me know how we can progress this proactively.