File out of memory - not be able to open

I get this:
File out of memory
It’s no longer safe to edit as Figma may not function properly.
Closing other tabs and reloading Figma may reduce browser memory and allow you to open this file.
If that doesn’t work, restore this file to a previous version to continue editing.
For more help, visit our [Help Center].

What I have tried:

  • clear cache and cookies and reload ----- not working
  • try to restore from the history, but I can not even click on the "show version history’ button, it’s not working. After clicking on that button and the history list only displays for 0.1 second and gone.
  • download the desktop app and get the same result

Any way Figma team can help me to restore to the latest version on you end?
or any idea? thanks.

1 Like

You can restore a previous version of a file from a file browser. Check out these help center articles:
https://help.figma.com/hc/en-us/articles/360038006754-View-a-file-s-version-history#Restore_from_version
https://help.figma.com/hc/en-us/articles/360040528173-Reduce-memory-usage-in-files

If You Even Can’t able to Restore the previous versions of All the saved version Then Follow the steps as per i tell
if The screen keeps on showing file out of Memory then

Step : 1
you just open in your mobile and Login the creditial as same you are using in your System, you can only able to view the file Not to Edit,

Step 2:
so you come to your system and go to home page of figma and go to the Project where you were working, and right click on the project and click on Share Option ,

step:3
you create new Account in figma and add that Email id in Share as to only View.

step:4
You will get notification to that added Email ID and, login with that new Account you can view the designs,

step: 5
Once you can view the design then You Just try to Select All Frames and Copy Ctrl + C and Paste In new Page You will Get Back your Design with Edit Option and you can still work On with The Same design pages

Just Follow These Steps Definetely You can Backup all the Desing Files Back to Work

1 Like

Is this still an issue you are facing?

Same problem :sob: my team mates can see the file, I get memory issues?