Figma Mirror Android hangs when trying to load frame

Figma Mirror will not work.

It just hangs on a black loading screen, forever. No amount of logging out, logging in, installing, uninstalling, blood sacrifices, etc seem to do the trick. I’ve tried with the web instance, to initiate the mirror as well as the native instance. My iPhone works completely fine under all the same conditions.

Figma Version: 21.5.1
Android Version 12 (Up to Date)
Google Pixel 3XL


Yep got the same problem was working fine earlier today.

having same issue today :frowning:

Same here on Pixel 3xl, android 12. Tried app reinstall, phone restart… still stuck on black screen.

Same issue here on all Android devices we have… iOS seems to be working fine.

I have the same issue

Same here :cry:

Same problem

Yeaa Experiencing the Same Issue

Figma Mirror Stuck at Mirror Loading Screen with a Loading GIF

Facing Same issue from morning in multiple android devices

I’m mirroring the screen , it starts loading but it doesn’t show the screen on phone. The loader keeps on rotating. I have already updated the Figma mirror.
Same issue is happening with other devices also. I’m using android device.


Yes I am facing the same issue today… It was working fine yesterday.

1 Like

Same here… I am facing the same issue

1 Like

Same issue on all Android devices we’ve tried. iOS seems to be working fine. Issue is also reported here:

1 Like

I am facing the same issue on my Android device. But mirroring seems to work fine on IOS device. The screen just shows a black screen with a loader and does not sync the screen. Please let me know how to fix this.

I have been experiencing this problem since today morning. The figma mirror screen is just stuck at this screen doesn’t work on any frames and I have even checked with other phones. I have rebooted my device twice, checked the network, uninstalled the app and reinstalled it still not solved. If anyone knows how to solve this problem pls let me know

I am experiencing the exact same issue since today. It worked without issues yesterday.
Clearing cache, reinstalling, even switching from Figma Desktop to Figma’s Webview did not solve this mirroring problem

Same here, hope they fix it soon

Hi, it shows loading but doesn’t load. I’ve updated Android version and reinstalled figma app - nothing works