Dropdown menu for Smart Animate, does not ease in and out well for subsequent lists

I have a problem with my smart animate, ease in and out. I have a drop down menu with 10 expandable list, the first 2 columns transit in and out nicely, but the 3rd column down does not appear the same, it flashes and in an instant changed to expanded mode (not transitioning smoothly).

Please help me with this issue. Appreciate it.

Thank you

1 Like

Does this occur on a desktop prototype as well as mobile?

If it does then the problem is that this animation is a heavier render for Figma, therefore it lags and does this flash, I don’t really think it’s solvable by us other than lowering down the prototype size as much as we can.

Basically if you are absolutely certain there isn’t a setting issue then it’s the same issue I described above, you can report it but I don’t think it would do much. It might be something else that I’m unaware of or didn’t come to mind though. I’d advise to go through the settings once more and make sure nothing is wrong.

Edit: Oh! Forgot to mention, you don’t have to use smart animate to create a smart animation, you can do it with the different animations such as slide in/slide out, move in/out, etc. while checking the “Smart animate matching layers”.

Hope this helps! Best of luck!

Thank you for your reply. It happened on a desktop and mobile view. I am using animation - and choose ease in and out effect. I have also copied and paste the same setting to the rest of the list/menu, probably Figma is unable to manage the render as you mentioned, or there is a bug?