[CHROME] cannot open Figma file with hardware acceleration on

Hi, I have an using when using the Figma.

When I disable the Chrome Hardware acceleration, I am able to open the Figma without any issue, albeit slower.

But when I enable the chrome hardware acceleration setting, everytime I open Figma, my browser will flicker once, and says that my browser did not support WEBGL.

Is there anyway to fix it?

I need to enable the hardware acceleration for other chrome features. But then I won’t be able to use Figma if I do so.

Hi @Tsasqa_Galih ,
Is this happening on a specific file or all the files?

If this is happening on a specific file, then it might be possible the file has reached its memory limits.
Figma is a browser-based app, which means it’s subjected to a 2GB available memory limit that applies to each browser tab, including those in our Desktop App. When loading or editing Figma files nears or exceeds this memory limit, it can cause performance issues like long load times or crashes.

I recommend you to:

  • Reduce the size of the file will usually help with load speed
  • Reduce the size of individual pages (for example by splitting a page into multiple pages) will usually help with rendering performance.
  • Hidden layers: loading and then hiding a large number of layers, especially in components or with images stored in them, can cause a high use of available memory on loading.
  • Stacked Masks and Effects like shadows and blurs also take a lot of memory to load.

You can find more tips in our Help Center article on how to Reduce memory usage in files that will help you to avoid hitting this limit again.

If you are still running into issues despite these workflows, you can reach out our support team so they can take a deeper a look into your issues here. Hope it helps!

1 Like

Hi @Celine_Figma

It’s happening to all files actually.
Which is weird since i can still access all files without issue if i turned the browser hardware acceleration off.

i also tried using my other laptop with the hardware acceleration on to open all the files, and it does not have the same issue.

Hi @Tsasqa_Galih ,
Thank you for the details!
Can you also ensure WebGL is enabled in Google Chrome? The steps to do this are in this article: https://help.figma.com/hc/en-us/articles/360039828614-Configure-your-browser-for-Figma#Update_settings

If it is still doesn’t fix your issue, please reach out to the team by filling this form with all detail you recall (WEBGL issue, happening to all files, affecting browser and/or desktop etc): here
Our technical team can investigate further. Thank you!

thanks Celine. i followed the steps needed on the article and it still doesnt work.
but i’ll fill the form you provided.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.