Change To interaction disabled, variants not selectable

This problem occurs in more than one place, but I’ll describe the “Creating interactive components” frame here:

  1. The Change To interaction is not selectable, although it is shown in the screenshots (I mentioned this in this bug also before I realised it is happening in multiple places.

  2. It seems impossible to hook up the Default Variant button to the Hover variant button, as it is not shown in the list, and dragging the arrow around only makes it snap to the label of the button (which obviously doesn’t make the hover effect work)

Hey there,
Change to interactions can only be created between variants in the same component set. Can’t surely tell from the screenshot, but it looks like you’re trying to connect a variant across two component sets.

Does that help? Can you maybe share more context over what you’re trying to achieve?

1 Like

Interactive components are created among variations, and you want to do from an instance. The variants are in the purple outline frame. It is in this frame with variants that you can use “Change to”.


hello Ovan,
I think I ran into your same issue: make sure you are logged in with the account you used to request Beta access.
I use different accounts, educational ones for teaching, the ones provided by the agencies (working as a consultant), and my personal one just for testing, sometimes it is a little confusing :-).
It looks like for the moment the new functionality is available only for the enabled accounts. Bye.

1 Like

Hi Giancarlo, I’m testing this from the beta account. It worked on an earlier version of the shared file. Thanks

I know, it used to work before, but for some reason it stopped working: as you can see the snapping does not occur on the button but only on the label or on the variant group.
Can't snap on a button variant

Why are you doing this? I don’t understand why you are creating interaction from an instance. For interactive components it should look like the screenshot below:


Aha! Fair point, and that’s where the confusion came from.

In the next frame/example you create the interaction on the button below. I believe I did them in reverse order, hence why I tried from the bottom button.

Thanks for solving the mystery.

For me, it is not working! See the screenshot below.

Please help!

Can anyone help me here? It would be fantastic

Hi @tiagorangel. Could you share a link to the file?

Yes. It is the frame “Trip details” (or) “Trip details (active love)” of the file The file is in construction…

The love icon

Thank you very much, @tank666 !

@tiagorangel, your file doesn’t have a component set, which should contain variants of this component, between which you can select “Change to”. Please see the Help Center article:

It does not working for me! See the screenshot below.

You create interaction between different components, but you need to do it between variants of one component.

Read the help center article at the link above.

1 Like

Thanks :slight_smile:

Oh thanks! :grin:

it works!