Figma Support Forum

[Bug] Figma prototype UI obscuring fixed website header

  1. Describe the problem your experiencing and how your idea helps solve this
    Screenshot and sample file below. I’m using an iMac sized frame with extended height. This issue is exacerbated by the fact that this is the now the default view when using multiple flow starting points and is the only way to actually change the flow starting point. So you have a constant trade-off of whether you want to see the Figma controls or your prototype’s. Annoying as hell.

EDIT: When sidebar is hidden, the fixed header is visible but inaccessible. As soon as the cursor hovers near it, the Figma UI appears over the (clickable) website header. Wow…

  1. Add as much context as possible (screenshots, Figma files, mockups, etc.)
    https://www.figma.com/file/WlYbWyHwtBGEFZihdMt2az/Bug-Obscured-fixed-header?node-id=0%3A1

4 Likes

I have a very similar issue that evidenced itself as quite a problem in client presentations last week. I normally keep the UI off at all times in a presentation, but with the introduction of flows I found it very useful to have the client view the flows list after finishing one flow to proceed to the next.

However the only way to access the flow list is turning on the full UI. I need my client to review the designs at 100% size, but this caused the header to be overlapped by the top bar and centered footer buttons are impossible to click with the screen index controls that appear on hover. Ideally, 100% files would start under the top bar and stop just above the index controls so we could keep the UI up and just hide the flows sidebar.

2 Likes

The UI at the top obscuring the visual is incredibly annoying and unnecessary. It just needs fixing there with an option to show/hide.

3 Likes

Agreed! When sharing prototypes with clients the header menu (not just the fixed ones) in all of my prototypes is inaccessible. It’s embarrassing having to explain clients how to switch it off.

Come on Figma, you can’t be serious about this!?

1 Like

I always hide the ui, but I would like to see the flow option. I only hide the UI because it’s always covering my top menu. Please fix this!

With one of the latest Figma releases the top navigation overlaps the presentation screen. As the navigation is fixed top to the viewport, users can’t access navigation hotspots.

What I am looking for is to be able to share with team or clients a UX wireframe in presentation mode so they can access all hotspots on the screen - at anytime.

Any ideas?

You can hide the UI in the prototype options (dropdown on the top right). If you share the link after that, the UI will be hidden for viewers as well.

Thanks @Gleb - makes sense. Though once I share the prototype with the UI hidden viewers can’t bring the UI back therefore they can’t comment on it.

So I am left with 2 options if I am correct:
a. I share the prototype with the UI top navbar overlapping the main navigation and viewers can comment but not browse; or
b. I can share the prototype with viewers with the UI hidden but they can’t comment

Do you believe a resolution to this could be brought forward as a valuable UX improvement to the tool?

Thanks

1 Like

The toolbar can be shown with Cmd/Ctrl + \ — this tooltip is shown at the bottom of the screen when opening a prototype with hidden UI. That can definitely be improved though. I think the simplest improvement would be to make the toolbar not overflow the content (this doesn’t make much sense anyway).

Couldn’t find my answer on the forum so though to post a question myself. The top of the design in prototype is cut off. The Figma info bar is laying on top of the page. Since no one is asking this question I think I am doing something wrong here?

Hey @Justin_van_Oel ,
yeah I find that counterintuitive as well. How this works is you have to hide the Figma UI prior sharing. You can use Cmd/Ctrl + \ or go under Options > Show Figma UI (uncheck/hide)
After you got it hidden - use the share link.
Try that should work.

Bumping this up - ideally I’d still like viewers to see the sidebar with the flow starting point links, and the top bar overlaying the content doesn’t seem logical.

Cmd+\ also doesn’t work in all cases as some third party software uses this shortcut as well.

1 Like
  1. Figma’s UI header shows up and covers my prototype’s header. I know that there is Hide UI function, but people who watch me prototype don’t. They struggle to click on my header and cannot.

  2. I suggest shifting Figma’s panel above the prototype. Without overlay. I believe it will solve the problem. Thank you.

1 Like

Hi @Maria_Berezneva :slight_smile:
I was dealing with the same issue for a while, but I eventually realized that you can hide/show it by pressing Command+. just like the panels in the work space.
Hope this help :v:

This looks like a bug. In a preview mode, I’m trying to preview my work - so why would they cover it up with their UI - it makes no sense. Currently it is not even semi-transparent, it’s solid black.

Grrrr.

This may have to do with the display settings. If you change it from 100% to fit or fill it should help in stopping the UI from covering up the frame.

Changing the display settings doesn’t change the issue really. It would just shrink the view of the frame, but now it’s out of scale and too small and is more confusing in some ways. I think this goes to show some glaring issues with some basic functionality around prototyping for Figma. I love Figma but the fact there isn’t some parity with features InVision had had for years like pages being scrollable, choosing an area that can be sticky to control what scrolls, and things like that is kind of surprising.

Hi @Phil_Schroeder - I am just chiming in here. When you say “pages being scrollable, choosing an area that can be sticky to control what scrolls” - I believe those functionalities are covered. You can definitely set objects as “Fix Positioned” in the application which would then reflect as “sticky” in the prototype. I believe the current best resolution to this problem here is to use Cmd/Ctrl + \ to hide the Figma UI in prototyping mode. If you share that link the users will exactly see the same - the prototype without the Figma top navigation. However, as mentioned earlier, in my opinion this does not completely solve the issue as you will have to explain your users how to toggle the navigation back in if you want them to access the toolbar to accessing features like commenting. So, this is a usability issue. I should not need to be put in a position to explain my users on how all this works - it’s over-complicated - so there is an underlying issue with the current solution.

This is obviously a bug and it’s crazy it hasn’t been addressed sooner. It never used to behave this way, you shouldn’t have to close part of the UI to see the top of your design when viewing at 100%. Please @Figma can we get some support here.

1 Like

This is a bug that needs to be fixed.