Auto animate on hover buggy

Hey,

i noticed that my mouse needs to rest for a second before the auto animation on hover works properly. Check the video for more information.

Do i need to change something in my settings? Is anybody else experiencing this problem? I’m using the desktop app for macOS.

Hey @Benny_Stuhler, the on hover interaction should trigger an instant transition.

As our first troubleshooting step, can we try clearing out your cached files and see if that helps?

You can clear the desktop app cache on a Mac in the Help menu under Troubleshooting.

If you’d prefer to manually clear your cache you can:

  1. Quit the Figma desktop app
  2. Open Terminal.app and enter the following command: rm -rf “$HOME/Library/Application Support/Figma”
  3. Try opening the desktop app again

Hey @Gayani_S
clearing the cache didn’t help.

Here is the file for testing:

Apologies for the delayed response @Benny_Stuhler! I’ve changed the prototype interaction to see if it helps (on click open to “Datei ausblenden hover state” and when mouse leave “Datei ausblenden default open state”). It still shows a delay of 1 sec. I’ve asked now internally to the teams to check if there are any other workarounds. I’ll update you once I have a response!

Appreciate your patience!

1 Like

Hi @Benny_Stuhler,

sorry for the delay! The team confirmed that this looks like a bug.
They were also able to reproduce this consistently. So I’ve created a support ticket on your behalf. Your ticket number is #916383, for reference. Our technical quality team can investigate on this case further.

I am going to share your link to the file with our team. Please invite support-share@figma.com with “can edit” permission. Note that users with @figma.com emails on your team do not count towards your billing.

If you’re unsure on how to invite someone to a file, please follow these steps:

  1. Click the “Share” button at the top-right corner of the Editor
  2. In the next window, type support-share@figma.com into the text box
  3. Select the “can edit” permission option
  4. Click the “Send invite” button

Please let me know if you have any further questions.

Thanks,
Gayani

Hey @Gayani_S

no problem, thanks for your help :slight_smile: i’ve invited the Figma support team to the file.

1 Like

Just in case someone ends here with the same problem. The workaround is to use mouse enter/leave within the components

Example: https://www.figma.com/file/L0XhefUiDZxvhL91rVstMA/button-hover-workaround?type=design&node-id=0%3A1&mode=design&t=RZzn08TdsM4NypEE-1