Figma Support Forum

An error occurred while adding an instance of this component

Today I’ve tried to drag and drop the component as usual from the Assets panel but there is an error message for some components.

Screen Shot 2021-01-29 at 11.12.26

I’m not sure what happened in my component library since there is no specific update in those components. Previously, I have the same error experience with different components then it resolved itself without updating anything.

I found a similar issue in the Spectrum forum but it’s still not yet resolved https://spectrum.chat/figma/general/error-when-adding-a-component-from-library~d0438c1d-4513-48ca-8da8-1de6ff8a9f08

Does anyone know how to solve this problem?

Thank you

1 Like

Seems like you found a bug, you should send a report to Figma Support via the support request form or support@figma.com.

1 Like

Thanks, Gleb. I’ve just sent the report to the Figma Support :+1:

I copied solution from @Laura (Figma’s Support Team). She gives me some options to solve this issue and it’s work well.

(1) Republish
Try to unpublish and republish the library that have an error. Unpublishing a library won’t break any existing connections with subscribed files.

(2) Update the component which has an error
Try to make changes to the main component (such changing the opacity to something like 99%). Publish the update of the component to the library. Accept the update in the other files using that component.

Still don’t know why it’s happened but I’ve tried the second options then now it’s works well.

Thank you :raised_hands:

7 Likes

Hm… unfortunately the first option to Unpublish the library only resulted in an error about unpublishing the library haha. The second one is harder to pinpoint, as it doesn’t really indicate what component is the bottleneck.

This happens to me often in our icons file. I’ve done both of these solutions multiple times already. I always do (2) first but when that doesn’t work, I end up doing (1). Sometimes on rare occasions, that doesn’t work either so I just end up doing (2) again which usually fixes it. Basically, just going back and forth of doing the two options which is a bummer and a huge time suck.

Hopefully, this gets fixed soon.

Hey, I’ve also been getting this issue with our icon library. In order to fix it I’ve been modifying the variant slightly (like updating the description of it) and republishing. It works, but definitely is an insane time suck.

Hmm, sadly have been getting this error now too. Unpublish and Republishing Library did not work. But making changes to a component did.

Makes the Asset panel workflow kind of useless since it’s just giving errors if you try to drag an item from the Designsystem for example. Hoping for a fix soon.

1 Like

Hello,

Two days I go a colleague got an error message when trying to add a component from our common library. For me, it still works without issues (On macOS)

We have already tried these two suggestions I found on a similar thread, but they didn’t work.

(1) Republish
Try to unpublish and republish the library that has an error. Unpublishing a library won’t break any existing connections with subscribed files.

(2) Update the component which has an error
Try to make changes to the main component (such as changing the opacity to something like 99%). Publish the update of the component to the library. Accept the update in the other files using that component.

This is happening for both the Web and the desktop app on windows.
Any suggestions?

Thanks a lot.

Closing and re-openning desktop app has helped me.

1 Like

+1, Closing and re-opening the desktop app worked for me too

I closed the file tabs within Figma before quitting and re-opening the desktop app, and that worked. Simply quitting Figma while the tabs were still open and then re-opening didn’t work for me.

Hello guys,

I’m facing a similar problem here. I have tried all the solution that you guys mentioned and it didn’t work. After doing analysis and troubleshooting here and there, finally, I can solve it after checking the broken main component and pushed override the instance contained by the broken component.

2 Likes