Use local fonts

I have Figma on my Mac and can access local fonts but just not in my browser. I have followed the instructions here:

Any solutions?

I have this same problem!

Hey All, sorry to hear you’re having trouble accessing your local fonts in the browser!

Can you please confirm if you have the Figma font service installed & working?

You need to install the Figma font service to use your local fonts in the browser. To confirm it’s working:

  1. Go to the Fonts section in your account settings to see if the font service is installed on your current device.

Followed the steps installed Figma agent and nothing happens.

Hey @Allan7, thanks for the screenshot!

Did you reload your tabs after installing? From your screenshot, it looks like you still need to Download the installer.

Downloaded and installed from the Figma site then tried via account-fonts and reloaded tabs. Still no fonts.

Thanks for confirming!

Have you tried clearing your browser cache or another browser?

Yes. It’s showing up in Chrome but not Safari.

Thanks for the context. Is this happening:

  • In new files or only existing files? If only in new files, this generally means you need to Manage conflicting fonts
  • For all fonts you have installed locally or only a specific font?

It’s all my files and all local fonts. Can’t see them except on desktop version or in Chrome browser.

Thanks for letting us know, @Allan7!

This seems to be a Safari specific bug. Please use Chrome or the desktop app as a workaround, and we’ll file this as a bug. Our team will try to reproduce and work on a fix.

1 Like

Hey! Just want to point out that I’m having the same issue using Safari 16.5.2 (18615. on a M1 Pro MacBook Pro running Ventura 13.4.1. So this issue is not exclusive to this user