Unable to view "Change Variable Mode" icon in layer panel

It is a new fiature and it is very glitchy because of that

I’ve found that if a component doesnt want to show modes changing icon in Layer block — then I must assign at least one to the component properties, f.e. boolean to its visibility (if I dont have to hide it dynamically) then the mode icon appears.

Whats more interesting — when I clear the boolean set by variable — the set mode icon vanishes but IF I’ve chosen the mode for this component other than (Auto) — it keeps this parameter (it is seen in layers panel on the left) though there is no button in interface to change it…

1 Like

Similar to someone else in this thread, the tokens option for Layers wasn’t showing up for me until I made both primitives and tokens. I’m trying to get everything to resize (padding, gaps, and width) when moving the design from say a desktop frame to an iPad frame.

As you can see, I’m not seeing the tokens option for a blank frame, which I find odd. But I do see it when I have a frame that has designs in it.


Here are my primitive and token settings for what I’m trying to achieve.