Unable to view "Change Variable Mode" icon in layer panel

Hi ,

Unable to view the “Change Variable Mode” icon in the layer panel after the creation of variable

I am able to see the icon in Page level

I am using Figma Professional licence

Thanks in advance

Dear Reaz,

Make sure, you have set prior created variable to an element of that specific page. Once you assign any variable to an element, the icon will appear.

Hey Thanks Zhorzhik,

Below is FYR

Or you can select a button to see avalable variables, or you can change variable modes of all page from right top corner, marked with yellow in the screenshot.

In case of issues, please share the file to explore and assist you)

I had the same issue and I tried to set every element with a different mode then the icon shows up.

I have the same problem. I do not see the “Change Variable Mode” icon in the layer panel after the creation of variable. I have applied variables to a frame and set 2 mode, but I do not see an icon next to the layer panel.

1 Like

This is because you may be using figma free version. I am also facing this same issue due to free version. I am also facing single mode in creation of variable. When i click on plus button to add second mode it require pay for 12$. We request from figma team please allow at-least two mode to free figma plan. 4 mode for paid plan.

When i click on plus button to add second mode it require pay for 12$.

Hi, I have the same issue. I have a professional license. I can see the icon on page level, and I can create several modes, but I can’t see it on the layer level. I have updated, restarted and reloaded Figma. Have anybody found a solution to this?

Does not work on layer level


Now it works, not sure what did the trick though. I tried publishing all new variables. I also tried to put mode on more collections (both primitives and tokens collection) etc, so maybe something of that did the trick, not sure.

I was having the same problem of not seeing the mode selector in the layers module. I had two collections, primitives and tokens. The mode was only set on the tokens but I was using primitives so naturally the mode selector didn’t show up.

I have been running into the same issue. I have a pro license and my file is in a team project folder, so that is not the issue. When I create variables with modes, I am able to set the page to the mode but if I add a section frame, the layers box in the design tab does not offer the variable icon. I have had success by creating the section then closing Figma and reopening it, the variables icon then showed up in the layers box. While this has worked some of the time, it still doesn’t work most of the time. My guess is that it is a Beta bug but if there is a known reason why this is the case or I am doing something wrong, I’d love to know. Here is a link to an example file where this situation is occurring. https://www.figma.com/file/yT49Qt0bCQFyNJDhF5Srwl/Variables-Training?type=design&node-id=0%3A1&mode=design&t=8p0LN3VRBhBkhz8G-1


Do you mean that when a section is selected that does not contain nested layers, in the Design panel under Layer section you cannot set variable modes? So in this case, everything works as expected, since there is not a single layer in this section in which you can change the variable modes.

Thank you for that clarification. It totally makes sense now why the option was not showing up yet.

Hello, I have the same issue. Some elements on the same page can see the “Change Variable Mode” icon in the layer panel, but some can’t. Even when the “Change Variable Mode” icon shows up, it cannot select the selectors inside the mode.

I have set up two collections, but I can only view one collection at a time after I click the “Change Variable Mode” icon.

Here is an image I made a few weeks ago, when I was able to choose the selectors from the mode. Thank you for your help.

Is the variable bound to the “Purple/600” style fill?

Your collection has only one mode.

I have the same issue too. :frowning: