Figma Support Forum

Text input doesn't work in FigJam

  1. Describe the bug/issue you’re running into?

Text input doesn’t seem to work. No text shows up as I type.

  1. Are you able to consistently reproduce it? If so what are the steps?

Create or edit any sort of text node.

  1. Share a screenshot, recording, console log, link to the file, etc.



Sometimes see this “Missing font replaced”:

  1. Is the issue only happening in desktop app or a specific browser , or both?

Not sure, I only use the browser version

  1. What OS/version and/or browser/version are you using?

Chrome 89 & macOS Big Sur 11.2.3

3 Likes

I’m seeing the same thing. In the desktop app and the latest version of safari on macOS Big Sur.

2 Likes

Screenshot 2021-04-21 at 20.38.14

Same thing here. Extra info: when I switch from ‘Normal’ to ‘Heading’ it says that a missing font is replaced. In the iMac desktop app (MacOS Catalina 10.15.7) and on the latest Chrome, version 89.0.4389.128.

Same here, console says: “FGTextData.cpp: Can’t insert text due to missing font” when I try to write text on a sticky.

1 Like

Hey Everyone, Thank you so much for reporting. We’ve logged this and our team will be looking into it. Thank you! :mag:

2 Likes

Ditto. Getting the same issue on Firefox 88 on MacOS 10.15.7 Catalina as well as in the desktop app despite reboots of my macbook pro and restarts of Figma.

Hi! Are you all able to edit text in Figma Design as well? Or just FigJam?

To help us debug this, can you please share what’s happening in the developer console’s “Network” tab? Here’s a video for how to do that: Loom | Free Screen & Video Recording Software

Make sure you:

  • Open up the developer console (right click on the toolbar, click “Inspect”)
  • Switch to the “Network” tab
  • Refresh the tab
  • Create a sticky note and try adding text
  • Scroll up in the “Network” tab till you see the related requests (in this case, it’ll have a title like “Inter-Medium_2”)
  • Please upload a screenshot that includes the font network requests and a screenshot of anything that looks unexpected (eg failed requests)

Thanks!

2 Likes

I can edit text in Figma Design.

Just noticed this warning in the console on each keystroke in FigJam:
[TextEditor] FGTextData.cpp: Can't insert text due to missing font

Here is the network tab on a page reload (filtered to font files):

It seems like the Inter woff files are downloaded okay.

There are also 2 failed GETs to a localhost address:

GET http://127.0.0.1:44950/figma/font-files net::ERR_CONNECTION_REFUSED

GET http://127.0.0.1:44950/figma/desktop/can-open-url?userID=917631671659615259&url=https://www.figma.com/file/vm5fl0sODhCbS5fZROwrBZ/Untitled?node-id=0%3A1 net::ERR_CONNECTION_REFUSED

Both from vendor.78ec9d3dd772e4ab8a78f07a4f4bb4a1.min.js.br

Thank you for the quick response! @Graham_Murdoch, can you also filter by “Inter” in your Network tab? We’re thinking that it’s possible this XHR request for Inter-Medium_2 might be one of the culprits.

Doesn’t seem to request that one.

Ah! I uninstalled my local Inter (in Font Book) and text editing is working in the browser (Chrome) and in the macOS app now.

I had the Inter font family installed locally. I downloaded it from Google Fonts a while back. I think it would be nice to keep that locally installed.

1 Like

Same, I had the font “Inter” installed locally as well and it wasn’t working in Chrome Version 89.0.4389.128 (Official Build) (x86_64) on Mac Catalina v. 10.15.7. I disabled the font using Font Book and reloaded the page, this allowed me to start using the text tool. Got the same message in console before about not being able to insert because of a missing font.

We just shipped a change we think should solve this issue. If you leave Inter enabled in your Font Book, refresh your tab, and try creating text, does it now work?

cc @Graham_Murdoch @Josie @Sean_Sands @grg

1 Like

I enabled it and refreshed. It’s working! Thank you!

4 Likes

Yes, can confirm it works for me now even with a local Inter installation enabled. Excited to use FigJam now!

3 Likes

Resolved as well; excited, thanks!

3 Likes

I got it to work, but not initially. I refreshed my safari tab, closed and reopened the file in the desktop app, but it still didn’t work. So I opened font book and had to disable the inter font. It then worked. I was then able to re-enable inter and it kept working.

1 Like

Looking like its working now. happy dance

1 Like