Subtract from frame

Hello everyone!

I know that you can subtract shapes to make different shapes. I would like to do the same with a frame, as I want to have an overlay with the shape of a tetris block. I’m getting the feeling that this is not possible. Am I right? Are there any workarounds?

I would appreciate any answer :slight_smile:

Hi @Nikki_Pim_van_Hooren,

Not a proper “solution” but a workaround : have you tried to create a vectore, that you can shape the way you want, and then use it as a mask on your frame, as shown below?

let me know if it helps

1 Like

I have a question, what type of object is the ‘card’ in your example? It does not look like a frame

It is, it’s a Frame with auto-layout activated. Don’t worry this works the same whether the frame is an auto-layout or not

Hi, again, I tried it with different vectors/shapes but it doesn’t seem to work. The full frame stays visible even when in a mask group while the vector/shape is never visible. See screenshots below:


Had to post this image seperately

You probably have the clip content option check on Frame 1 in Masked group, check on the right panel for this

Uncheck it and it should work just fine

That was indeed the issue regarding the visibility. Now I have a hand-shaped frame, but the problem now is that I cannot use it in an interaction. This is probably due to the fact that the frame is inside a masked group. Is there another workaround for this?

Is there something preventing you to put Masked group into an another frame so you will end up have something like that :

Frame 2
  Masked group
    Frame 1

Then you will be able to interact with Frame 2

I’ll have to make the frame transparent because I want the background around the shape to still be visible but I guess it works. Thanks for the help! I’ll mark your answer as correct

1 Like

Regarding the same problem,

I have a “Frame” that I want to mask it with a vector shape. I put the vector shape, on top of my frame. I select both and from the top nav, I select the Mask icon.

I don’t know what’s the problem, but instead masking my frame with the selected shape, the whole shape becomes a fill on top of the frame.

I’m confused don’t know what to do.

:blush: :blush: :blush: :blush: :blush: :blush: :blush: