Reset component state does not work

I made a button dropdown component using an already existing button component with variant prototypes in place. When I am creating adding an onclick function on my button dropdown, the button state does not reset and stays the same as the initial state.

When I prototype the dropdown, the button stays in the default state (The spelling stays CTLA and the chevron stays pointing downward instead of upward)

Hi there,

Thank you for reaching out. In order to investigate this further, could you please share a screen recording or the file link?

I’ve tried to replicate the issue on my end and everything seems to be working fine, as you can see in the attached video.

Please let me know if there’s something I’m not catching!

Thanks,
Toku

Hi @y_toku . Thanks for the response. I am using an existing “button” component inside the new “button dropdown” component I created. Can that be the issue?

Here is the screen recording of the issue -

Thanks for the screen recordings! I tried again to replicate it on my end but it works fine on my end.

Could you share your file link and give us (support-share@figma.com) to investigate further? If you prefer, DM would be fine as well. By the way, inviting us won’t affect your billing :slight_smile:

Thanks,
Toku