Figma Support Forum

Proto Preview Blank when Interactive Components Used

When interactive components are enabled, I try to preview my prototype and it’s just black/blank.

I’ve enabled the starting frame, set a frame window size and tried in the Beta Mac OS app as well as the Normal Mac OS Figma app and Google Chrome. Unchecking the Enable Interactive Components link allows my prototype to be displayed.

I’m also not doing any complex time delay interactions or anything either, just some simple color changes on hover.

It happened to me as well. The strange thing is that it worked for a while and then it just stopped. No complex interactions as well. I got color change at hover.

Same for me. Worked fine until last week, now I get a black screen unless I uncheck interactive components. What’s really weird is one project with interactive components gets the black screen, while another does not.

Same thing just happened to me. I have a pretty complex flow with interactive components involved. It’s been working great for the last 2 weeks or so. Suddenly, today it gave me a black screen when I entered the prototype. I reverted back to a save from yesterday and duplicated the file, and that prototype worked fine. So somehow, something changed between last night and this morning that caused this bug. I barely made any design changes to the file in that time period, so not sure what it could be.

1 Like

This is happening to me as well.
I’m designing a mobile app and curiously, the prototype works great in the Mirror app (iOS).
On desktop thought, I see only a black window.

It’s actually creating a pretty big roadblock for our team, but I guess I shouldn’t have gone into the beta… :slight_smile:

Yep, happened here also. It took me 20 minutes just to realize it might be the cause.

Hey all - we pushed out a tentative fix for blank preview / black screens today. If you’re still experiencing the bug, please DM me! Links to problematic files are helpful if possible.

2 Likes

Thanks, Andrew! Fixed for me.