No prompt to sync library updates

Since yesterday evening, after I publish library updates, I am not prompted to update the components in the file where the library is available. I also don’t see the updates when going to libraries → updates. If I close and reopen Figma, the update prompt appears instantly.

1 Like

Hi there! Thank you for flagging this. Our team is aware of this issue and has implemented a fix.
Please refresh your browser / the app in order to see the fix.
And, please let us know if you still encounter any issues!

It seems to be fixed now. :pray:

1 Like

Yeah … this issue is still persistent on some of the files (not all of them). Would be nice for this to be fixed properly. Really annoying.

The only fix I could find is copy/paste from library to the file, but event the new copies don’t update properly if I make any changes in the library.

Libraries syncing is getting worse and having a huge impact productivity. In the design file I can see updates available (sometimes), yet I can’t click to preview changes (loading spinner from hell), I click on the update and the component in the file is still not updating. I spend so much time trying to fix the issues that its becoming ridiculous.

Hi there! I have the same issue for several weeks now. We use several library files and several files linked to them and no matter where I make an update, the update doesnt come up in the file referenced to. The only fix is to restart the file, then the message comes up. The problem only occurs in my desktop app, all other team members using the same files dont get into this.

Is there another solution for fixing that problem?

Heu Philipp! Sorry to hear you are having issue. Please reach to our support team so they can investigate further, as these can be related to another issue here: https://help.figma.com/hc/en-us/requests/new
Be sure to use your Figma account email, include a link to the file, and share it with support-share@figma.com so they can take a closer look. Thank you!

I’m still seeing this issue as well. I have seen it using three different libraries and many different files. I have to close and reopen all files to get the component update prompt. I am running the latest version of Figma Desktop ( v116.15.4)

Same issue here for months, very annoying…

Hi everyone,
As a workaround, can you please try to clear out the cache to see if that helps? Please follow the steps for the browser and desktop app here: https://help.figma.com/hc/en-us/articles/360040328553-Use-Figma-while-offline#clear-data

If this doesn’t help, I’d recommend you to reach out directly to the support team: https://help.figma.com/hc/en-us/requests/new. They can investigate what is causing this.
Be sure to use your Figma account email, include a link to the file, and share it with support-share@figma.com, so we can take a closer look. It may also be helpful if you can also share a screen recording of the issue so we can take a look at what you’re seeing when publishing updates and then trying to receive them on another file. Thank you!

1 Like

Clearing the cache in the Figma desktop app fixed things. Now I just have to see how long the fix sticks for.

Oops! That didn’t last long. Back to no alerts for component updates.

I’m experiencing the same issue. Not all files get the prompt to update the library which is hugely time consuming since it’s something I do maybe 100 times a day…

I tried re-install Figma and duplicating the file but the prompt won’t show up

Same here :confused:

I have the same issue, need to constantly reload the tab to get publish updates from the library file.

I still have the same issue… I’ve had this for months, but now is getting worse, before was enough to close and open the tab file, but now I have to restart the whole Figma app to get the update, really annoying.
At least, if it is not prompting automatically, would it be nice if we had a button where we could click to kind of “force a double check if there are updated” functionality or something like that…

I’m having this same issue, it worked fine untill last week. I just created a topic for this issue today when I came across this thread. My topic:

Older files still update libraries with displaying the dialog box every time, but newer files won’t displays the dialog box. It shows it once, after startup, but from then on I need to update components manually… It’s workflows hell for me.

I wish I just could set it to update automatically.

Same here, update dialog is not consistent. Sometimes I see it, sometimes not. Without it I have to click on each component to update it 1 by 1 which really impacts productivity and creates inconsistencies.

My team has been seeing this behavior intermittently for months as well. I thought it had been resolved but I’ve heard new reports this past week.

I have the same problem for a couple of weeks now. The library updates notification just simply stopped showing on all files. I have to manually update it by going to the Assets tab, and clicking the library button.