Library updates does not trigger "Review Update" dialogog box

Hi there. I have a strange problem.

I created a new library and design file and everything was working great until a week ago.
I’m working on Windows 10 with the Figma desktop app.

At some point, after updating a component, the “Review update” dialog box did not appear anymore. I can still update the components manually with the circle-arrows-update icon in the component settings. But when I have to update multiple components I need to do that manually for every component. I can’t update all.

Older files still have the review update dialog box and other colleagues do not experience this issue.

What’s happening here?

Just to add something and to make it more complex.

The Review update dialog box DOES open once in the new design file when I restart Figma. But only once. After that, I need to update the components manually as I described above.

Hi there,

Thanks for the post. Please let me share the current expected behavior:

  • The Review/Update pop-up toast will appear just on the page there are updates to be accepted on - however if you don’t accept all the updates after clicking this, this toast will not appear for future updates (unless the file is refreshed)
  • The black dot on the assets tab will only appear if there are updates on the page you’re currently on.

The information is here: https://help.figma.com/hc/en-us/articles/360039234193-Review-and-accept-library-updates#h_01HGV42MNB9W9RNKXMZ292T7AQ.

If the problem looks different, please feel free to reach out to our support team via the form: https://help.figma.com/hc/en-us/requests/new. They should be able to help you further!

Thanks,
Toku

Let me see if I understand this correctly :

  • The review / update toast appears
  • I don’t accept the toast
  • Toast will not appear again unless I refresh

Let’s dig deeper into what you’re saying about the toast :

  • I do the steps above
  • I refresh the Figma file
  • I see the toast that was not accepted
  • I accept the toast
  • Will this toast continue to never show up again until I refresh or is it supposed to ‘reset’ the toast function of ‘not appearing again if I’ve dismissed it’?

I believe, based on what you’ve said that there is some problem with this mechanic that it is now forcing me to reload my file every time I push changes because I didn’t accept the changes once.

Side note :

I have tried fixing it by “Resetting my cache” concept, also checked to see if my components have variables with the same name. However the issues associated with those are that they can’t update their components at all, I can - I just need to reload the page to get the toast to show up.

No, this is not what’s happening.

I just don’t get the toast anymore in new files. With older files, I do get the toast every time when updating, but in a new file, I don’t get the toast.

In a new file, I will get the toast once(!) after Figma startup if there are components that still need to update. When all components are updated, and I change multiple components in the library, I will not get the toast. Instead, I need to update every component manually through the inspector on the right with the update icon.

It’s not that I’m not accepting the updates. I do. But if I make changes, a toast will only appear if a restart Figma. After that, it won’t display any updates.

— Update —

I can get the toast now. Not sure what changed, I didn’t do anything to my boards.

  • Adding and removing elements from components reveals toast

  • Modifying vectors reveals toast

  • Modifying component, Dismissing toast, and pushing again toast does not appear
    ** Manually Updating components, Updating all components
    ** after 1 min - Toast is still not appearing until reload of the page
    ** after reloading and triggering toast, toast now appears regularly

After some Q&A :

I did a few things, Review update, Update Selected instance, etc. those things will not trigger the toast again, however making updates, pushing, reloading the page to trigger the toast, updating from the toast, toast now triggers every time.

Screenshot 2024-01-11 at 12.16.03 PM

I thought that maybe the review or Update Selected had some influence on this but it didn’t. Seems like it’s just working as it should for me now.

1 Like

Yes, what Sean has described is also working for me (for now). The strange thing is, you would think that a restart of the whole desktop application would also invoke the reloading of a page, but this had no effect. So why is this different?