Figma Support Forum

Missing Libraries

I was creating a library for my team in Figma but when I opened the libraries modal, it said I have missing libraries. I tried to delete all the pages but it still said “Missing Libraries”, does anyone have a solution to that? Or it was a bug in Figma? Thank you!

Here is the example file: https://www.figma.com/file/nx2kyqZi1Kkbi5P4H9Lh1I/🧪Global-Design-Library-Copy?node-id=180%3A7431

2 Likes

When you click on the “Missing libraries” it would show you which items specifically are coming from the missing libraries. I can find these styles used in the file so this seems to work as intended.

Thank you for your reply, Gleb! I tried to find those styles in the file but I don’t see them even after I deleted all the pages, the problem still persists. FYI, when I clicked on the “Missing libraries”, it directly went to the screenshot below.

I am wondering if there are styles in the missing libraries, should it display how many styles like other libraries?

If you delete everything and reload the page, it removes the cached library items from the file so they will no longer show in in the “Missing library” view.

No, the number of items is not shown in the “Missing library” item. This is working as normal too.

Thank you for your response, Gleb! You are right, after I deleted all pages and reload the file, the “Missing library” doesn’t show up again.

However, if I keep these pages, I couldn’t find the missing styles mentioned in the missing library modal in any layers. Or I missed anything in the file?

For example, “heading / h1”, I couldn’t target where it is being used in the file. :pensive:

It seems like there are some bugged styles which are attached to text nodes but not shown in the UI. You can either ignore them or do some modifications to texts (e.g. change font size and then change it back) to reset the “ghost” style.

image

1 Like

Got it, thanks for helping look into the problem, Gleb! Really appreciated!
As these are bugged styles, not something I did wrong or affect the design, I’ll leave it for now (there are too many text layers in my real library file :joy:). Hope there will be an easier solution to reset/remove the “ghost” style in the future.

Out of curiosity, I used your method to change the font size (same example file in the original post) and reset it back, and made sure all the text layers didn’t have a “ghost” style (using the command line you provided in the screenshot). Then I reloaded the file, it seems the problem of “Missing library” still persists :sweat_smile:

image

Maybe it’s stored on instances in some way, I’m not sure. Anyway, it doesn’t cause any issues. And the whole “Missing libraries” thing is there just for your information/convenience if you actually need it. But if you don’t — you can ignore it.

1 Like

True, thank you for your reply!

4 posts were merged into an existing topic: Need a way to find Missing Library components/styles